Closed Bug 337312 Opened 14 years ago Closed 8 years ago

If only one .htm or .html file is attached to a message sent by Thunderbird, Outlook 2000/2003 inverts the body of message and attachment when displayed

Categories

(Thunderbird :: General, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: ihoffmeier, Unassigned)

Details

(Keywords: testcase)

Attachments

(3 files)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.3) Gecko/20060326 Firefox/1.5.0.3 (Debian-1.5.dfsg+1.5.0.3-2)
Build Identifier: Thunderbird 1.5.0.2 (20060308) Windows

If only one HTML file is attached to a message composed in Thunderbird, that message will show the HTML file inline and the body of the message as a .txt attachment when viewed in Outlook 2000/2003.  The name of the .txt attachemnt is typically ATT00002.txt.  However, if 2 HTML files are attached, the proper behavior occurs:  The body of the Thunderbird message is shown inline, while the 2 HTML files are shown as attachments (that might be displayed inline beneath the body).

Reproducible: Always

Steps to Reproduce:
1.Compose new message in Thunderbird
2.Write some text in body
3.Attach one .htm or .html file
4.Send the message
5.Open the message in Outlook 2000/2003

Actual Results:  
When the message is viewed in Outlook 2000/2003, the body of the Thunderbird message will be an attachment named ATT00002.txt (or some similar numeration) and the HTML file will be displayed inline.  This occurs no matter how Outlook and Thunderbird are configured, i.e. set only to text or to block images, etc.

Expected Results:  
The message sent by Thunderbird should be displayed in Outlook so that the body of the oringal message appears inline and the HTML file is attached (or displayed inline beneath the body of the message).

I tested this using the following, all of which behaved exactly the same:
* Mozilla Suite 1.7.13
* Thunderbird nightly 3.0a1
* Thunderbird 1.5.0.2 (20060308)
* on XP SP2 machine
* with Outlook 2000/2003
Please do the following: create a test message following your Steps To Reproduce.  Send it to an Outlook recipient.  Verify that the message appears incorrectly there.  View the message in your Thunderbird Sent folder.  Verify the message appears correctly there.  View|Source of the copy in the Sent folder, and do whatever the Outlook equivalent is on the receiving side -- check if there's a difference.  (There shouldn't be.)

If none of that behaves as expected, please provide details why.

If on the other hand it all checks out, then: why is this Thunderbird bug?
Attached file tbird_sent
Attached file outlook_inbox
Did as you asked.  The "sent" message from Tbird in fact is different than the "inbox" version as viewed in Outlook.  Both are attached.  I had to slap the headers onto the top of the Outlook version.

I understand your implication that this may not be a problem with Thunderbird, but I suspect the issue has to do with A) how Thunderbird marks the content type of an outgoing message with the characteristics I initially described in this bug or B) how Outlook interprets such an incoming message as sent from Thunderbird.  If it really is B, then I agree, not your problem.

Please tell me what other info I can provide.  Hopefully, the message headers/content will help.
(In reply to comment #4)
> I had to slap the headers onto the top of the Outlook version.

But those headers are not correct for the message body you provided.  You put
  Content-Type: multipart/mixed  
while the body is strictly text/html.

I haven't played around with Outlook, so I don't know how it gets messages and I don't know why you can't save the entire message source directly.  Are you getting the message via an Exchange server?  It may be a problem with the way Exchange chooses to present MIME parts.


> I suspect the issue has to do with A) how Thunderbird marks the content
> type of an outgoing message with the characteristics I initially described
> in this bug 

From what I know of MIME, the 'Sent' copy you provided is correctly marked up, and that should be exactly what was provided to the SMTP server.  Beyond that, it's out of TB's control.
The headers are correct.  Exchange was not involved at all.  Both email clients connected to the same IMAP server.  Outlook, being the subpar product that it is, forces you to grab the full headers of an email by going to View -> Options, once the message is opened in its own window.  I then pasted those headers on top of what I got when I viewed the message source -- that message source actually being what was originally the HTML attachment.

If what exists is wrong, then I suppose we should assume Outlook incorrectly interpreted what Thunderbird presented and rewrote the headers (and flipped the body/attachment).

Not sure if it helps, but when I format the outgoing Thunderbird message with some HTML, say bolding, then Outlook will display the message properly.  It seems the problem occurs when the outgoing message is plain text -- even though I have Tbird set to compose in HTML and send as HTML anyway -- that Outlook flips the body/attachment.

Again, this could very well be an issue with Outlook, but it certainly doesn't hurt that folks who work on Thunderbird are aware of this behavior.
Could it bee because the html attached is noted as "Content-Disposition: inline;" when it should be "attached" ?
(In reply to comment #7)
> Could it bee because the html attached is noted as "Content-Disposition:
> inline;" when it should be "attached" ?
> 

I suppose it could be.  In that case, shouldn't the HTML attachment display inline below the original text of the body of the message?
Assignee: mscott → nobody
Keywords: testcase
Invalid for TB12.0.1/WinXP.

STR
1 open Testcase.eml attachment 246044 [details]
2 edit as new
3 send with TB, receive with OL 2003

Actual result

1) Testcase is multipart/mixed;
original text/html part is:
--------------020500040600020008090306
Content-Type: text/html; charset=UTF-8;
 name="test.htm"
Content-Transfer-Encoding: *7bit*
Content-Disposition: *inline*;
 filename="test.htm"

iow, html as plaintext in testcase.
2) But when sending, it's converted by TB into:

--------------010005080101080605080604
Content-Type: text/html; charset=UTF-8;
 name="test.htm"
Content-Transfer-Encoding: *base64*
Content-Disposition: *attachment*;
 filename="test.htm"

iow, it is technically impossible to send multipart structure of testcase with TB, because 7bit html as text part will always be converted into base64 mime part. The same happens when composing msg of same structure with TB.

3) testcase is correctly received and displayed by OL 2003, body text and attached .html file.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → INVALID
(In reply to Thomas D. from comment #9)
> Invalid for TB12.0.1/WinXP.
> iow, it is technically impossible to send multipart structure of testcase
> with TB, because 7bit html as text part will always be converted into base64
> mime part. The same happens when composing msg of same structure with TB.
...and content-disposition:inline is always converted into content-disposition:attachment because this is a real attachment within multipart/mixed.
You need to log in before you can comment on or make changes to this bug.