Closed Bug 337338 Opened 16 years ago Closed 16 years ago

Typing special characters (accents) and symbols with Option fails

Categories

(Core Graveyard :: Widget: Mac, defect)

1.8 Branch
PowerPC
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: bartvb, Assigned: mark)

References

Details

(Keywords: fixed1.8.1)

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en) AppleWebKit/418 (KHTML, like Gecko) Safari/417.9.2
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1a2) Gecko/20060509 BonEcho/2.0a2

Trying to enter special characters with the Option key (I.e. an u-umlaut with 'Option-u+u' doesn't work. Probably related to the event changes in bug 332579

Reproducible: Always

Steps to Reproduce:
1. Hold Option and press 'u' (You'll get ¨(just the accent) underlined)
2. Type 'u' (You get a ü underlined)
3. Try to type something else (you'll get this character underlined instead of the ü)

Actual Results:  
Every character you type (except for return) ends up being underline and in the place of the originally typed character

Expected Results:  
I expected a normal ü and being able to type afterwards :)

Using Bon Echo of today/last night.

BTW is there any way to use the normal bug entry form instead of the wizard?
Blocks: 332579
Version: Trunk → 1.8 Branch
Assignee: joshmoz → mark
Status: UNCONFIRMED → NEW
Ever confirmed: true
A fix for this problem is in byg 337199 patch v1 (attachment 221541 [details] [diff] [review]).
Depends on: 337199
Fixed in the build from bug 337199 (v8). The only problem so far is:

"One problem is that leaving composition mode isn't handled as cleanly as it
could be.  If you type (with a US keyboard) option-U,B, you would expect to see
umlaut,B (try it in a current release version), but instead, you just get the
umlaut."

(bug 337199 comment 5)

Great work, Mark!
Flags: blocking1.8.1+
*** Bug 338403 has been marked as a duplicate of this bug. ***
WFM on firefox-avairy1.0.1
---
Anybody tested this on trunk yet?
(In reply to comment #4)
> WFM on firefox-avairy1.0.1

Who cares?

That branch is over a year old, and this bug was specifically reported against the 1.8 branch.  It also occurs on the trunk.  No additional testing is needed.  I positively know what caused this bug and already have a reviewed patch awaiting superreview.  I've also got test builds and feedback from testers indicating that the patch fixes it.
Fixed by checkin of bug 337199.
Status: NEW → RESOLVED
Closed: 16 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.