nsXULAppRunner needs updating after bug 214672: remove nsIZipEntry

VERIFIED FIXED in mozilla1.9alpha1

Status

VERIFIED FIXED
13 years ago
3 years ago

People

(Reporter: alfredkayser, Assigned: alfredkayser)

Tracking

Trunk
mozilla1.9alpha1
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

13 years ago
nsXULAppRunner needs updating after bug 214672: 
findEntries now returns a UTF8StringEnumerator so that GetNext no longer returns a nsIZipEntry but a entry name string. Also replace "*" with null (no pattern match). Patch following real soon!
(Assignee)

Comment 1

13 years ago
Created attachment 221673 [details] [diff] [review]
Patch to update XULAppRunnerSetup after bug 214672

Robert, this code needs a little update after bug 214672.
Can you review this? Thanks in advance!
Attachment #221673 - Flags: review?(robert.bugzilla)
(Assignee)

Updated

13 years ago
Component: Networking: File → XULRunner
Flags: review?(robert.bugzilla)
Product: Core → Toolkit
(Assignee)

Comment 2

13 years ago
Comment on attachment 221673 [details] [diff] [review]
Patch to update XULAppRunnerSetup after bug 214672

Requesting review (somehow the previous request got cancelled...)
Attachment #221673 - Flags: first-review?(robert.bugzilla)
Comment on attachment 221673 [details] [diff] [review]
Patch to update XULAppRunnerSetup after bug 214672

Looks good
Attachment #221673 - Flags: first-review?(robert.bugzilla) → first-review+
(Assignee)

Comment 4

13 years ago
Comment on attachment 221673 [details] [diff] [review]
Patch to update XULAppRunnerSetup after bug 214672

Darin, a small followup to bug 214672. Can you do the SR and checkin? Thanks in advance.
Attachment #221673 - Flags: second-review?(darin)

Updated

13 years ago
Attachment #221673 - Flags: second-review?(darin) → second-review+
(Assignee)

Comment 5

13 years ago
*** Bug 342488 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

13 years ago
Blocks: 214672
Alfred, do you need someone to check this in?
Assignee: nobody → alfredkayser
I went ahead and landed this because of bug 342488 comment 3.
mozilla/xulrunner/setup/nsXULAppInstall.js 	1.5
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9alpha1
(Assignee)

Comment 8

13 years ago
Thanks!
Comment on attachment 221673 [details] [diff] [review]
Patch to update XULAppRunnerSetup after bug 214672

>   _installZipEntry : function ze_installZipEntry(aZipReader, aZipEntry,
>                                                  aDestination) {
>     var file = aDestination.clone();
> 
>-    var path = aZipEntry.name;
>-    var dirs = path.split(/\//);
>+    var dirs = aZipEntry.split(/\//);
>     var isDirectory = path.match(/\/$/) != null;
                        ^^^^
oops
Depends on: 362686
> oops
->  bug 362686
(Assignee)

Updated

10 years ago
Status: RESOLVED → VERIFIED
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.