Middle click to open in new window should work in sidebar

VERIFIED FIXED

Status

P3
minor
VERIFIED FIXED
19 years ago
14 years ago

People

(Reporter: david, Assigned: bugzilla)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
In bug #6085 the middle mouse button was changed so that middle clicking a link
in the browser window would open the linked page in a new window. The same
thing should happen when you middle-click a link/bookmark in the sidebar. Akkana
should know the details about how to make this happen.
(Reporter)

Comment 1

19 years ago
See bug #33761 as well (middle click in bookmark pulldown)

Comment 2

19 years ago
akkana do you want this bug
QA Contact: paulmac → shrir

Comment 3

19 years ago
Links in sidebar panels should be inheriting all behavior (context menus,
middle-mouse-button opening, drag-and-drop ability, whatever) from the behavior 
of normal links in Web pages, and doing so automatically without anyone having to 
code anything twice.

If this isn't happening, there's something a wee bit wrong with the architecture, 
and this bug should be resummarized to the more general case of doing all the 
same things as normal links.
(Reporter)

Comment 4

19 years ago
Well, the sidebar has one additional thing that the main window never has, and 
thats bookmarks. This bug was added as recommended by akkana. I'd be interested 
to hear from the people at netscape what they think?

Comment 5

19 years ago
The middle-click behavior is set up in navigator.xul for the box "appcontent". 
Maybe it just needs to have the same onclick= code added somewhere else to cover
the sidebar?

If our architecture were ideal, then mouse events would be handled as an XBL
behavior just like key events are, and we'd be able to set up a style that
specified certain behavior on certain mouse events.  Alas, mouse events aren't
covered by any configurable system like XBL (we were lucky to get key events in
for this release), so we have to handle the event explicitly in XUL files
instead.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 6

19 years ago
Would an XUL overlay work to give sidebar items the same context menu as normal 
links? (Or is my ignorance showing?)

Updated

19 years ago
Target Milestone: --- → M18

Comment 7

19 years ago
Move to M21 target milestone.
Target Milestone: M18 → M21

Comment 8

18 years ago
More generally, it would be nice to be able to set a preference so that clicking
on a link (anywhere) would _by_default_ open a new window and that opening the
link in the current window would be a menu selection
(Assignee)

Comment 9

18 years ago
Reassigning 50 Sidebar bugs to Matt.  I was told this was going to be done 
shortly about two months ago, but it clearly hasn't been.  I think that's long 
enough for all these bugs to remain assigned to nobody.

Feel free to filter all this spam into the trashcan by looking for this string 
in the message body: ducksgoquack
Assignee: slamm → matt
(Assignee)

Comment 10

18 years ago
reassigning to me to fix.
Assignee: matt → blakeross
(Assignee)

Comment 11

18 years ago
Wait a sec.  I already did this.  It's not working?
Status: NEW → ASSIGNED

Comment 12

18 years ago
*** Bug 60713 has been marked as a duplicate of this bug. ***

Comment 13

18 years ago
this is working great for me on today's trunk build on linux(20001120). Marking
Fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 14

18 years ago
This isn't working at all for me in Windows build 2000112104, neither bookmarks
or "ordinary links" (such as the one at the top of the tinderbox tab). I'll test
linux later when I have some more time
(Assignee)

Comment 15

18 years ago
Add this to your prefs.js file:

user_pref("middlemouse.openNewWindow", true);
(Reporter)

Comment 16

18 years ago
Ok, I agree that it works if I edit prefs.js as indicated. Two questions though:

1) When will middle-click to open in new window be implemented for bookmark tab 
in sidebar? (should I file a separate bug for that?)
2) Will the "middleclick to open in new window" be made a pref in the "normal" 
Edit->Preferences GUI?

Comment 17

18 years ago
marking this verified (1127)
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.