Closed Bug 33761 Opened 20 years ago Closed 15 years ago

Middle click to open in new window should work in bookmark pulldown menu

Categories

(SeaMonkey :: Bookmarks & History, enhancement, P4)

enhancement

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 272800
Future

People

(Reporter: david, Assigned: ben_seamonkey)

References

(Blocks 1 open bug)

Details

(Keywords: helpwanted)

In bug #6085 the middle mouse button was changed so that middle clicking a link
in the browser window would open the linked page in a new window. The same
thing should happen when you middle-click bookmark in the bookmark pulldown.
Akkana should know the details about how to make this happen.
(also see bug #33758 for the same report about sidebar)
This is an RFE, really. Confirming.

Gerv
Status: UNCONFIRMED → NEW
Ever confirmed: true
Ooh, this sounds kinda tricky.  RFE, mFuture
Summary: Middle click to open in new window should work in bookmark pulldown menu → [RFE] Middle click to open in new window should work in bookmark pulldown menu
Target Milestone: --- → Future
Reassigning 79 Bookmarks bugs to Ben.  I was told this was going to be done 
shortly about two months ago, but it clearly hasn't been.  I think that's long 
enough for all these bugs to remain assigned to nobody.

Feel free to filter all this spam into the trashcan by looking for this string 
in the message body: ducksgoquack
Assignee: slamm → ben
Netscape Nav triage team: this is not a Netscape beta stopper. adding helpwanted 
to the keywords
Keywords: helpwanted, nsbeta1-
Severity: minor → enhancement
OS: Linux → All
Hardware: PC → All
Filed bug 72361 to cover ctrl+clicking in the bookmarks menu.
akkana: Any tips on how to make this happen? I've been looking around, but I 
can't see it...

Gerv
Akkana: Thanks, but that's not what's needed.

This bug requires two things: 
A middle click on the actual top-of-the-browser-window bookmarks menu to do 
"Open In New Window".
A middle click on the bookmarks pulldown that optionally appears in the Personal 
Toolbar to do "Open In New Window". 

The problem is that neither of these objects is a context menu. I understand 
context menus. I suspect that this is a lot harder than it might at first 
look...

Gerv
Would be really cool (and natural/logical) if middle-clicking on a bookmark in
the personal toolbar opened the bookmark in a new window.

(I don't know if it's related codewise - if a seperate bug should be filed for
this personal toobar RFE, let me know :-))

  /Adam.
Adam: middle-clicking on personal toolbar items is covered by bug 59132.  (See
bug 70501 for a list of "middle-clicking on x should open a new window" bugs.)
Blocks: 85375
See also:
 93032 - personal toolbar
 93033 - bookmark manager (4xp)
 93034 - throber
Status: NEW → ASSIGNED
Priority: P3 → P4
Paul Chen is now taking Bookmarks bugs. For your convenience, you can filter 
email notifications caused by this by searching for 'ilikegoats'.

Assignee: ben → pchen
Status: ASSIGNED → NEW
No longer blocks: 85375
mass reassign of pchen bookmark bugs to ben
Assignee: pchen → ben
Summary: [RFE] Middle click to open in new window should work in bookmark pulldown menu → Middle click to open in new window should work in bookmark pulldown menu
Blocks: 72361
Status update:

I recently tested this in Firebird and Mozilla nightly trunk builds (from
2004-01-19).

It works just fine now in Firebird but not in Mozilla.
Mass reassign of my non-Firefox bugs to ben_seamonkey@hotmail.com
Assignee: bugs → ben_seamonkey
*** Bug 249724 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
272800 is really a dup of this but the patch got attached there so...

*** This bug has been marked as a duplicate of 272800 ***
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.