Manually Edited URL Preempted by History Drop Down

RESOLVED DUPLICATE of bug 327101

Status

()

--
trivial
RESOLVED DUPLICATE of bug 327101
13 years ago
13 years ago

People

(Reporter: peter, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3

If the URL is selected using the location bar drop down and is edited before the last slash (/), the original URL, instead of the edited one, is used when enter is pressed.

Reproducible: Always

Steps to Reproduce:
1. Press down arrow to activate location bar drop down.
2. Select an URL with multiple slashes (e.g. http://www.example.com/original/123).
3. Before activating the URL, use the mouse or keyboard to edit some part of the URL (e.g. change to http://www.example.com/changed/123).
4. Press enter.

Actual Results:  
Browser navigated to http://www.example.com/original/123.

Expected Results:  
Browser navigates to http://www.example.com/changed/123.
As far as I know Firefox goes straightaway to the selected url after selecting it in the dropdown without even the possibility of editing it first.
So this is normal behaviour.
Please retest in Firefox's safe-mode or with a new profile.
This to rule out extension influences.
Please reopen if you can give more detailed steps to reproduce this in a Firefox with a new profile.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

13 years ago
The bug is reproducible in safe mode. However, I just realized that the actual steps need to reproduce it is much more obscure:

1. Begin typing a pre-existing URL in location bar.
2. As the history drops down, use down arrow to select a URL.
3. The new URL (http://example.com/original/123) is now visible in location bar, and the drop down is still visible.
4. Use CONTROL-LEFT-ARROW to navigate the URL component by word boundary.
5. Change the URL (http://example.com/changed/123). Note that the history drop down is still visible at this point.
6. Press enter.
7. Firefox navigates to original URL (http://example.com/original/123).
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
With ctrl+left arrow I can only place the cursor one word to the left.
A more handy way to change the url seems to be wiped out with the back button.
Then there is no problem navigating to the edited url.
(Reporter)

Comment 4

13 years ago
> With ctrl+left arrow I can only place the cursor one word to the left.

You can get to more words to the left by continue to press the control-left arrow keys.

> A more handy way to change the url seems to be wiped out with the back button.

Do you mean backspace or the back button? If you mean backspace - I agree.

I have verified that this bug does not occur with 1.0.7, so it seems to represent a regression bug. Specifically, in 1.0.7, the history drop down goes away as soon as you edit the URL. The problem with 1.5.0.3 seems to be that the lingering of the history drop down, as you are editing the URL inline, which afterward causes the browser to go to the original/wrong URL. (At least, this is a guess without looking at the source code).
Summary: Drop down selected URL with slash overwrites manually typed URL → Manually Edited URL Preempted by History Drop Down
Yes, it regressed somewhere around August 2004.
There is still the possibily that this is a dupe, but I have no time at the moment to find it out.
(Reporter)

Comment 6

13 years ago
I am probably one of five people on the planet to encounter this bug. :)

Degraded severity to trivial.
Severity: minor → trivial
Regression between 2004071817 and 2004072011.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Regression from bug 251513, then. I'd say this is a dupe of bug 327101.

*** This bug has been marked as a duplicate of 327101 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.