Any subsequent opened browser window shows up briefly completely white

RESOLVED WORKSFORME

Status

()

Core
Layout
P3
normal
RESOLVED WORKSFORME
12 years ago
10 years ago

People

(Reporter: Martijn Wargers (zombie), Unassigned)

Tracking

({regression})

Trunk
mozilla1.9alpha1
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dbaron-1.9:RuCo])

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
This is a regression from bug 326273, because I noticed this also in Darin's earlier test builds.

The first window opens up completely fine, but when I open a second browser window, it briefly shows only white (like 200ms or so) before the browser shows up.
I'll attach a screenshot.

I notice it too when I open a new tab, for a short period, I see the browser chrome background color, and then it turns white. Before this regression, the background of the tab was always white.

Note, I have a fairly slow computer (800 MHz Duron). I suspect this may be particularly noticeable on slower computers.
(Reporter)

Comment 1

12 years ago
Created attachment 221812 [details]
screenshot

This is what I initially see (briefly, like for 200ms) when I open Page Info.

Comment 2

12 years ago
Bug 337575 deals with a different issue, however the same effect is there described as possible circumstantial evidence to trace down the problem.

Possibly both this bug and the actual problem described in bug 337575 have the same cause?

Comment 3

12 years ago
Think this is the same bug. When switching from Seamonkey to firewall and back the former firewall log screen stays grayed out, Seamonkey stops responding. If i switch desktop, the desktop will appear in the SeaMonkey window with SeaMonkey still not responding. Tried the event 5 times. 3 of the 5 times the SeaMonkey stopped responding.
(Reporter)

Comment 4

12 years ago
Sandy, that sounds like a completely different bug. Please file a new bug for that and try to find the regression range.

Comment 5

12 years ago
It's very slight on my T41 notebook, but I think I see the momentary white background as well in the page info dialog.  Very odd.  All I can imagine is that perhaps some paint event is now happening before other gecko events (perhaps all of the reflow events for XUL layout have not yet been run or something).  Hmm...

-> me
Assignee: nobody → darin

Updated

12 years ago
Status: NEW → ASSIGNED
Priority: -- → P3
Target Milestone: --- → mozilla1.9alpha
Does adjusting the paint suppression timeout change the behavior here?
Flags: blocking1.9a2?
Flags: blocking1.9a2? → blocking1.9+

Comment 7

11 years ago
-> reassign to default owner
Assignee: darin.moz → nobody
Status: ASSIGNED → NEW
Martijn, are you still seeing this?
Whiteboard: [dbaron-1.9:RuCo]
(Reporter)

Comment 9

11 years ago
I suspect this is worksforme, now.
I need to test it on my slow computer, however (which is almost impossible, atm).

But I don't think this should be blocking1.9+ any longer, because nobody else seems to have noticed this, thus far.
Making it so.
Flags: blocking1.9+
(Reporter)

Comment 11

10 years ago
I'm marking this worksforme, I haven't seen this for a while and I could reproduce bug 337993 by loading http://www.movenetworks.com/ in 2 tabs. But I couldn't reproduce this bug with that trick.
I still will keep an eye on this, though.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.