Messages lost during POP retrieval when disk really *is* full

RESOLVED DUPLICATE of bug 239455

Status

--
critical
RESOLVED DUPLICATE of bug 239455
13 years ago
11 years ago

People

(Reporter: briggs, Assigned: mscott)

Tracking

({dataloss})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.8.0.2) Gecko/20060427 Firefox/1.5.0.2
Build Identifier: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.8.0.2) Gecko/20060427 Firefox/1.5.0.2

When retrieving from a POP server, with messages being deleted from the server, and the (NFS mounted) disk with the local folder that was the destination really was full, Thunderbird popped up the dialog box saying it couldn't write the mail, however it had *already* deleted it from the POP server.

The result was a page of nulls in the folder for the page that failed, and MSF entries for the messages that weren't reallly there.   The messages displayed as empty, with only the info from the MSF file.

TB needs to make sure it can sucessfully write the message to the destination *before* it deletes the message from the server.

Reproducible: Didn't try

Updated

11 years ago
Severity: normal → major
Keywords: dataloss

Updated

11 years ago
Severity: major → critical

Comment 1

11 years ago
dupe of bug 239455 . The extra download in that bug is a result from 'leave mail on server' in combination with the corrupt mail store.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 239455
You need to log in before you can comment on or make changes to this bug.