Last Comment Bug 337815 - Messages don't show; summary-file increases every time Tb opens
: Messages don't show; summary-file increases every time Tb opens
Status: RESOLVED FIXED
: fixed1.8.0.7, fixed1.8.1, verified1.8.1.3
Product: Thunderbird
Classification: Client Software
Component: Mail Window Front End (show other bugs)
: unspecified
: x86 Windows XP
: -- critical (vote)
: ---
Assigned To: David :Bienvenu
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-13 03:29 PDT by Rob van Gelder
Modified: 2010-06-27 09:51 PDT (History)
1 user (show)
dveditz: blocking1.8.0.7+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Solution to missing mail while headers are shown, summary file increases (21.00 KB, application/msword)
2006-05-15 07:50 PDT, Rob van Gelder
no flags Details
proposed fix (1.67 KB, patch)
2006-07-15 15:39 PDT, David :Bienvenu
mscott: superreview+
dveditz: approval1.8.0.7+
Details | Diff | Splinter Review

Description Rob van Gelder 2006-05-13 03:29:27 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3
Build Identifier: Mozilla Thinderbird version /1.5.0.2 (20060308)

First issue noticed: I downloaded my email, nothing showed up in the inbox, though I could see the indicater that it was downloading 33 messages.
I could not retrace these after that, only headers I found but the message itself did not show.
After that:
Whenever I open Thinderbird the inbox will build a summary file. Nothing is shown in the message or subject pane, only after switching to another box (Send) and back it will show the headers, or will start rebuild the summaryfile again and then after another sequence it will show the the headers.
Clicking on a header gives an empty message pane, at this moment it reads in the bottom right corner that there are 31.778 mails, but i am certain there can be only about 2.500 max. This figure increases with approx. 2,500 everytime a summary file is build, everytime i open Thinderbird.

I tried to uninstall Tb, then download a new, latest version, restart, install and the same happends again.


Reproducible: Always

Steps to Reproduce:
1.open TB
2.Get mail or click inbox
3.click send
4. click inbox
 only now the headres show, but the message is empty.

Actual Results:  
The problem happends every time on one laptop. 
Another laptop, with the same software was used to compare all setting side-by -side to get identical settings.

Expected Results:  
The affected laptop did not show any of the messages.

show the message
Comment 1 Mike Cowperthwaite 2006-05-15 07:18:23 PDT
Do you have any extensions installed?  If so, do you see the behavior after starting TB in Safe Mode?

Is this for POP mail or IMAP?  If the former, have you ever compacted the folders?  (This rewrites the mbox files without the deleted messages in place.)
With a very large Inbox such as you report, there could be a problem here.  What is the size of the Inbox mail file now (before compacting)?
Comment 2 Rob van Gelder 2006-05-15 07:50:27 PDT
Created attachment 222035 [details]
Solution to missing mail while headers are shown, summary file increases

Thanks for your remarks,

I compacted the inbox folders,which went down from 155mB to 125mB
No extensions as i know of, it was happening in the POP3 inbox.

Problem is solved by experimenting with replacing files in folders and back again.
Comment 3 David :Bienvenu 2006-07-15 15:39:59 PDT
Created attachment 229361 [details] [diff] [review]
proposed fix

when we encountered a corrupt db, we were marking it invalid, but the code that recreates the new db from the corrupt one was not setting the version correctly, so that we thought the new db was corrupt, and regenerated it, forever. And we weren't clearing the total and unread counts when creating the new db either.
Comment 4 David :Bienvenu 2006-07-15 15:42:41 PDT
this patch is for 2.0 - it's also part of a larger patch I'm working on for the trunk that allows you to rebuild summary files from the folder properties dialog.
Comment 5 David :Bienvenu 2006-07-17 18:26:46 PDT
fixed on trunk and branch
Comment 6 David :Bienvenu 2006-08-02 15:18:29 PDT
Comment on attachment 229361 [details] [diff] [review]
proposed fix

this is a very annoying problem for users, and a frequent bug dup/tech support question.
Comment 7 David :Bienvenu 2006-08-14 12:14:26 PDT
this is an oft-duped bug, and a real pain...
Comment 8 Daniel Veditz [:dveditz] 2006-08-15 14:57:27 PDT
Comment on attachment 229361 [details] [diff] [review]
proposed fix

approved for 1.8.0 branch, a=dveditz for drivers
Comment 9 David :Bienvenu 2006-08-15 16:54:41 PDT
landed on 1.8.0.7 branch
Comment 10 Marcia Knous [:marcia - use ni] 2006-09-07 11:04:10 PDT
Rob: Can you try the build in this directory (ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/1.5.0.7-candidates/rc4/) and confirm that this addresses your issue?
Comment 11 WADA 2006-09-09 17:26:53 PDT
(In reply to comment #5)
> fixed on trunk and branch
David, can the patch produce Bug 351685 or can expose problem of Bug 351685? 
Comment 12 David :Bienvenu 2006-09-09 18:48:25 PDT
I was not able to reproduce bug 351685, at least on a 2.0 build on the mac. I'll try trunk and windows...
Comment 13 Carsten Book [:Tomcat] - PTO-back Sept 4th 2007-04-05 17:27:30 PDT
Verified fixed 1.8.1.3 i made several tests to reproduce this bug with the STR from comment #0 works fine for me and was not able to reproduce this bug.

-> adding verified keyword
Build: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8.1.3) Gecko/20070326 Thunderbird/2.0.0.0 Mnenhy/0.7.5.0 ID:2007032620 

Note You need to log in before you can comment on or make changes to this bug.