No visible focus indicator on image map areas with black background

RESOLVED FIXED in mozilla23

Status

()

Core
Layout
RESOLVED FIXED
11 years ago
4 years ago

People

(Reporter: Dan Kinnunen, Assigned: Takeshi Kurosawa)

Tracking

(Blocks: 1 bug, {access, sec508})

Trunk
mozilla23
x86
Windows XP
access, sec508
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

11 years ago
Env:Bon Echo 20060515 nightly build

Description:
When you TAB to a portion of an image map that has a black background, or a black image on a black background, there is no visible focus indicator.  There should be a dotted line around the image or image map area.

Firefox displays the visual focus indicator (dotted line) fine on areas with non-black background.  It appears to use a black dotted line, which is invisible on an image with a black background.  To contrast, Internet Explorer appears to "sense" the dark background of the image, and in that case uses a white dotted line instead of black to produce a visible keyboard focus indicator.

Recreate:
1. Load this URL in Firefox (Bon Echo):
     http://www.w3schools.com/html/tryit.asp?filename=tryhtml_areamap
    There will be a picture of the sun with two planets (mercury and venus)
     in the right pane of the window.
2. Press TAB until you see "sun.htm", "mercur.htm",  and "venus.htm" cycle through
    the status bar.  (It helps if you click the mouse on the text directly above
    the image, then press TAB.  

Error 1:  You should see a rectangular visual focus indicator (dotted line) around the Sun,
   then a circular dotted line around the 1st planet (mercury),  then a circular
   dotted line around the 2nd planet (venus) as you tab through the links.
   I assume the (black) dotted lines are actually there, but because of the black background, 
   they are invisible.  Firefox should sense the darkness of the background color,
   and use a white dotted line instead of black in this case.

Error 2: If you tab through the image map, watch the status line at the bottom of the
   Firefox window.  You see the status text cycle from ...sun.htm, to ...mercur.htm, 
   and finally to ...venus.htm.  If you keep pressing TAB past the venus link, notice
   that the status bar DOES NOT CHANGE as you continue to tab.  
   When you tab away from the link to venus.htm, the status line should be 
  blanked out, so it does not imply that the venus.htm link is still available
  at the new keyboard focus position.

You can find other images with this same problem.
For example, on the IBM.COM home page ( http://www.ibm.com/us/ )
The IBM logo image at the upper left corner has a black background.
If you tab to that image, you also do not see the visual focus indicator
(dotted line).
Confirmed on nightly trunk.

Updated

11 years ago
Blocks: 83552
Component: General → Layout
Product: Firefox → Core
QA Contact: general → layout
Summary: No visible focus indicator on images with black background → No visible focus indicator on image map areas with black background

Updated

11 years ago
Keywords: sec508

Comment 2

8 years ago
This is still an issue in Firefox 3.0.11, and also manifests in <input type="submit"> elements with a black background colour.
(Assignee)

Comment 3

4 years ago
Created attachment 716506 [details] [diff] [review]
Patch rv. 1.0

Patch

Draw focus indicator twice to make it visible.
At first, draw white solid indicator, then draw black dotted one.
Attachment #716506 - Flags: review?(matt.woodrow)
(Assignee)

Comment 4

4 years ago
Created attachment 716507 [details]
Screenshot with Patch rv. 1.0
Comment on attachment 716506 [details] [diff] [review]
Patch rv. 1.0

I don't think I'm the right person to review this. The code changes look fine, but I'm not sure if we need UI review for the change.
Attachment #716506 - Flags: review?(matt.woodrow) → review?(roc)
Attachment #716506 - Flags: review?(roc) → review+
(Assignee)

Comment 6

4 years ago
Comment on attachment 716506 [details] [diff] [review]
Patch rv. 1.0

Thanks comment and review!
Thus I flag ui-review.
Attachment #716506 - Flags: ui-review?(ux-review)
(Assignee)

Comment 7

4 years ago
Comment on attachment 716506 [details] [diff] [review]
Patch rv. 1.0

Hmm... I wondered ui-review is needed and there was no response.
So I canceled the request.
# but if it is needed, please set it again

Are there any required works or steps before requesting checkin-needed?
Attachment #716506 - Flags: ui-review?(ux-review)
(Assignee)

Comment 8

4 years ago
Created attachment 742685 [details] [diff] [review]
Refreshed Patch rv. 1.0 (using mercurial queues)

Patch rv. 1.0 against current mozilla-central
https://hg.mozilla.org/integration/mozilla-inbound/rev/beb08ab90a3d
https://hg.mozilla.org/mozilla-central/rev/beb08ab90a3d
Assignee: nobody → taken.spc
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla23
You need to log in before you can comment on or make changes to this bug.