Live bookmarks for Bookmarks Toolbar folders are created as normal bookmarks.

RESOLVED DUPLICATE of bug 338126

Status

Other Applications
CCK
RESOLVED DUPLICATE of bug 338126
12 years ago
12 years ago

People

(Reporter: Daniel, Assigned: mkaply)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2
Build Identifier: 

In CCK I added a folder for the Bookmarks Toolbar and put live bookmarks in that folder. But when installing the resulting XPI the live bookmarks are created as normal bookmarks.

Reproducible: Always

Steps to Reproduce:
1. see "Details"
2.
3.

Actual Results:  
see "Details"

Expected Results:  
see "Details"

The reason for this behavior is two bugs:
1. cckwizard.js, line 1443: must be "ToolbarFolder1.BookmarkType" instead of "ToolbarFolder1.Type"
2. cckService.js.in, line 530: must be 
bmtype = bundle.GetStringFromName(prefix + "Folder" + i + ".BookmarkType" + j); instead of 
bmtype = bundle.GetStringFromName(prefix + "BookmarkType" + i);
(Assignee)

Comment 1

12 years ago
Thank you for finding these. I fixed those earlier today as part of a different bug.

I appreciate your detail - those are exactly the problems I found.

*** This bug has been marked as a duplicate of 338126 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.