Search box leaks after being dragged from the customize toolbar dialog.

RESOLVED DUPLICATE of bug 296474

Status

()

Firefox
Search
RESOLVED DUPLICATE of bug 296474
12 years ago
12 years ago

People

(Reporter: Régis Caspar, Unassigned)

Tracking

({memory-leak})

Trunk
memory-leak
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

12 years ago
Using D. Baron leak Monitor, an object is leaked when you drag the search box from the customize toolbar dialog to the main toolbar.

Reproduce: always

Steps to reproduce:
1. Remove the search box from your toolbar if you have it here.
2. Install D. Baron 's Leak Monitor extension
3. Right-click your toolbar and choose Customize
4. Drag the search box and drop it on your main toolbar
5. wait for leak monitor popup (< 1sec.)

Actual results:
Leak

Expected results:
No leak
(Reporter)

Comment 1

12 years ago
Created attachment 222531 [details]
Leak monitor results
*** Bug 338487 has been marked as a duplicate of this bug. ***

Comment 3

12 years ago
Created attachment 225959 [details]
Leak Monitor Output

Comment 4

12 years ago
This seems to happen when you add/remove *any* toolbar widget on both branch and trunk.
(Reporter)

Comment 5

12 years ago
(In reply to comment #4)
> This seems to happen when you add/remove *any* toolbar widget on both branch
> and trunk.
I just tried with the "Star" button and got not leak alert..

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060711 Minefield/3.0a1 ID:2006071104 [cairo]

Comment 6

12 years ago
I tried with star and I got the leak alert.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060710 Minefield/3.0a1
(Reporter)

Comment 7

12 years ago
(In reply to comment #6)
> I tried with star and I got the leak alert.
I use Leak Monitor 0.3.4 and I'm under win xp sp2. Linux specific? (I checked and still see the leak alert for the search box)

Comment 8

12 years ago
I am seeing the search bar leaked when I shutdown (e.g. I see the object printed out in the console I started Firefox from) when I add or remove any toolbar item and just close the window.
OS: Windows XP → All
Hardware: PC → All
(Reporter)

Comment 9

12 years ago
Created attachment 228886 [details]
leak monitor output (2)

(In reply to comment #8)
> I am seeing the search bar leaked when I shutdown (e.g. I see the object
> printed out in the console I started Firefox from) when I add or remove any
> toolbar item and just close the window.
With a new window, I see the search bar leak when I remove the star button from the toolbar and close the new window. Additionally, I see another leak alert (see attachment)

*** This bug has been marked as a duplicate of 296474 ***
No longer blocks: 348344
Status: NEW → RESOLVED
Last Resolved: 12 years ago
No longer depends on: 230086
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.