crash [@ nsTextFrame::Paint]

RESOLVED WORKSFORME

Status

()

Core
Layout
--
critical
RESOLVED WORKSFORME
12 years ago
7 years ago

People

(Reporter: Anthony Martinez, Unassigned)

Tracking

({crash})

1.8 Branch
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.3) Gecko/20060326 Firefox/1.5.0.3 (Debian-1.5.dfsg+1.5.0.3-2)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.3) Gecko/20060326 Firefox/1.5.0.3 (Debian-1.5.dfsg+1.5.0.3-2)

I have obtained a stack trace and coredump with debian's firefox-dbg package. I am also filing this bug with them; it is bug #367956

Reproducible: Always

Steps to Reproduce:
1. Visit www.debian-administration.org, and a few other sites I cannot recall off the top of my head.


Actual Results:  
The title and RSS icon load, and then the browser crashes.

Expected Results:  
The title and RSS icon load, and then the remainder of the page should load, leaving the browser actually running.

This crash still occurs when I am in safe mode. I have not tested with a non-debian firefox.
(Reporter)

Comment 1

12 years ago
Created attachment 222541 [details]
stacktrace

Comment 2

12 years ago
Yes, please do try an official mozilla.org build.
Component: General → Layout
Keywords: crash
Product: Firefox → Core
QA Contact: general → layout
Summary: Segmentation fault in nsTextFrame::Paint, nsTextFrame.cpp:594 → crash [@ nsTextFrame::Paint]
Version: unspecified → 1.8 Branch

Comment 3

11 years ago
Anthony ... did you ever succeed to reproduce with official mozilla.org builds?
No crash with a current nightly or with Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.1.1) Gecko/20061205 Iceweasel/2.0.0.1 (Debian-2.0.0.1+dfsg-2) which is the latest in Debian testing.
-> WFM 

Please comment and if possible attach another stacktrace if you can reproduce on a current release or nightly.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

11 years ago
Oh, this is an old bug.

I found a workaround that I thought was posted here, but that seems to have been on the Debian BTS: Bug#367956, http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=367956 (Effectively, run with the environment variable MOZ_DISABLE_PANGO set)

I cannot reproduce this on the Swiftfox optimized build, nor the iceweasel Debian build, which I have been running without MOZ_DISABLE_PANGO for a while now.

Apologies for leaving you all hanging on this.
Thanks for the reply and the additional info -  good to know that this was tracked down to the packager.

Comment 7

11 years ago
I doubt this has something to do with the packager.

Sounds more like something that has either been fixed in mozilla pango code or in pango lib itself. Anyway, good to have this gone :)
(Assignee)

Updated

7 years ago
Crash Signature: [@ nsTextFrame::Paint]
You need to log in before you can comment on or make changes to this bug.