Closed Bug 338752 Opened 14 years ago Closed 13 years ago

Firefox will not uninstall using the uninstall/install utility in WindowsME Control Panel.

Categories

(Firefox :: Installer, defect)

1.5.0.x Branch
x86
Windows ME
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: george29115, Unassigned)

References

Details

User-Agent:       Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; Win 9x 4.90)
Build Identifier: N/A

Firefox won't uninstall.  I tried to uninstall Firefox in order to have a clean reload of the program.  However, it will not uninstall using windows uninstall utility in the Control Panel.

Reproducible: Always

Steps to Reproduce:
1.N/A
2.N/A
3.N/A

Actual Results:  
Program will not unintall using the windows uninstall/install program utility in the Control Panel of WindowsME.

Expected Results:  
There are no steps to duplicate or reproduce.

The software should have uninstalled itself.
It is not clear what Firefox version you're talking about.
If you are talking about the latest trunk, this is most likely a dupe of Bug 329237.
If you mean the latest release (Firefox 1.5.0.3), this is worksforme.
Problems with the Windows uninstaller can aways happen, with every installation of all programs. It can be caused by registry corruption, missing files etc.
*** Bug 338829 has been marked as a duplicate of this bug. ***
Probably WinME/Win9X specific (if anyone can reproduce).
(In reply to comment #3)
> Probably WinME/Win9X specific (if anyone can reproduce).
> 

Yes, it IS Win9xME specific and I am using Firefox 1.5.0.3.  When I installed
FF 1.5.0.3 under my bro's WinXP computer, the un-installer works as expected.
But when I tried to run the FF 1.5.0.3 uninstaller, it does nothing and freezes.
the FF 1.5.0.3 uninstaller works ok on win2k/xp systems but not under win9x/me systems.  btw - I'm using FF 1.5.0.3 under WinME and the uninstaller doesnt work under ME.
(In reply to comment #1)
> It is not clear what Firefox version you're talking about.
> If you are talking about the latest trunk, this is most likely a dupe of Bug
> 329237.
> If you mean the latest release (Firefox 1.5.0.3), this is worksforme.
> Problems with the Windows uninstaller can aways happen, with every installation
> of all programs. It can be caused by registry corruption, missing files etc.
> 

OR even a corrupted EXE un-installer file for Firefox.  if so, then the Firefox un-installer applet should be revised to fix the problems un-installing Firefox under 9x/ME versions of Windows.
Even Firefox 1.5.0.2 also had a faulty un-installer applet.  Tested FF 1.5.0.2 under WinME and tried to un-install it and nothing happens.  no dialog box asking whether to remove FF 1.5.0.2 or not.  had to use [Ctrl]+[Alt]+[Del] to close the Firefox un-installer and then delete the Firefox files and registry entries manually in order to remove Firefox.
Yup my hunch was right.  It was the uninstaller app itself.  When I installed Firefox 1.5.0.1 on another Win9x machine, the un-installer for that version of Firefox (UninstallFirefox.exe) worked correctly.  when I installed FF 1.5.0.2 or 1.5.0.3, they use a different un-installer (uninstall.exe) which did nothing and froze on a 9xME machine.  Good thing I copied the old uninstaller file [UninstallFirefox.exe] from the other 9x computer and placed it in the 'C:\Program Files\Mozilla Firefox\uninstall' folder on my WinME machine.  Then I ran UninstallFirefox.exe instead of uninstall.exe to remove FF 1.5.0.2 and it worked.  there were no corrupted registry settings on my Windows ME computer.  FF 1.5.0.2 and 1.5.0.3 just came with a bad un-installer.  maybe the older uninstaller [UninstallFirefox.exe] should be included in FF 1.5.0.4 since that one seem to work correctly on all 32bit versions of Windows including the 9x versions.
Perhaps the registry entry for the path to the uninstaller was not updated?
*** Bug 339149 has been marked as a duplicate of this bug. ***
(In reply to comment #9)
> Perhaps the registry entry for the path to the uninstaller was not updated?
> 

nope Robert.  The uninstall.exe file bundled in FF 1.5.0.2 and 1.5.0.3 is just faulty under 9xME editions of Windows [but works correctly under Win2k & WinXP].  I just used the older uninstaller [UninstallFirefox.exe] to remove FF 1.5.0.3 on my ME computer and the older uninstaller works.
also Robert I have triple-checked the registry entries of Firefox on my WinME computer.  they ARE correct.  If they are correct and up to date and the uninstaller for Firefox does not work, then the problem is with the actual un-install program of Firefox itself. even the RC and nightly builds of FF 1.5.0.4 that I have tested on the WinME computer have the problematic uninstaller.  Had to use the old uninstallfirefox.exe remover from FF 1.5.0.1 to uninstall FF 1.5.0.4 from my ME computer.  Hopefully the uninstaller problem will be fixed as soon as possible before the next release of Firefox.
The uninstaller and installer for Firefox 2.0 will be written with NSIS so it is completely different per bug 326580.
(In reply to comment #12)
> uninstaller for Firefox does not work, then the problem is with the actual
> un-install program of Firefox itself. even the RC and nightly builds of FF
> 1.5.0.4 that I have tested on the WinME computer have the problematic
> uninstaller.  Had to use the old uninstallfirefox.exe remover from FF 1.5.0.1
> to uninstall FF 1.5.0.4 from my ME computer.  

For the record, UninstallFirefox.zip contains UninstallFirefox.exe and can be found at  http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla1.8.0/windows-xpi/

See: http://forums.mozillazine.org/viewtopic.php?t=418369  




(In reply to comment #14)
  
> For the record, UninstallFirefox.zip contains UninstallFirefox.exe and can be
> found at 
> http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla1.8.0/windows-xpi/
> See: http://forums.mozillazine.org/viewtopic.php?t=418369  

thanks Alice.  so far the un-installer problem for Win9xME is not resolved in Firefox versions 1.5.0.5 and 1.5.0.6.  So those two versions also have the W9X Uninstall bug as well.

Anyway I am beta testing Firefox 2.0 beta 1 under Win98, WinME & WinXP and the uninstaller for FF 2.0b1 does work correctly under all supported versions of Windows including Win98/ME.
Version: unspecified → 1.5.0.x Branch
->WFM, fixed by 2.0 installer
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → WORKSFORME
(In reply to comment #16)
> ->WFM, fixed by 2.0 installer
> 

already knew that, Magnus.  ALL Firefox 2.0 releases have the uninstaller that worked correctly under Win98/ME.

(In reply to comment #14)

> For the record, UninstallFirefox.zip contains UninstallFirefox.exe and can be
> found at 
> http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla1.8.0/windows-xpi/
> 
> See: http://forums.mozillazine.org/viewtopic.php?t=418369  
> 

Alice, the UninstallFirefox.zip file no longer exists at the link you mentioned.
(In reply to comment #17)
> 
> Alice, the UninstallFirefox.zip file no longer exists at the link you
> mentioned.
> 

ok.  found another copy of the file here:
http://releases.mozilla.org/pub/mozilla.org/firefox/releases/1.5.0.1/win32/xpi/UninstallFirefox.zip
(In reply to comment #11)
> (In reply to comment #9)
> > Perhaps the registry entry for the path to the uninstaller was not updated?
> > 
> 
> nope Robert.  The uninstall.exe file bundled in FF 1.5.0.2 and 1.5.0.3 is just
> faulty under 9xME editions of Windows [but works correctly under Win2k &
> WinXP].  I just used the older uninstaller [UninstallFirefox.exe] to remove FF
> 1.5.0.3 on my ME computer and the older uninstaller works.
> 

Update on the faulty uninstall.exe file included in Firefox versions 1.5.0.2 to 1.5.0.12; I've tested the uninstall.exe file under Windows NT4 and it works fine.  So it looks like the FF 1.5.x uninstall "freeze" problem seems to occur under only Windows 9xME-based OSes and not under NT-based Windows OSes.
The problem is reproducible on all attempts of Mozilla's Aurora on every platform. Must be an installation problem. 

I deleted all instances of program on all drives starting with c:\program file\Aurora and Mozilla.

No other solution that actually works was found. You can try downloaading a new instance of program and reinstalling over old program but you will still have litter in your registry.
You need to log in before you can comment on or make changes to this bug.