If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Camino 1.0.1 crashes when loading certain webpages

VERIFIED WORKSFORME

Status

Camino Graveyard
Plug-ins
--
critical
VERIFIED WORKSFORME
12 years ago
11 years ago

People

(Reporter: Seamus Mulryan, Unassigned)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-us) AppleWebKit/312.8 (KHTML, like Gecko) Safari/312.6
Build Identifier: 2006042704 (v1.0.1)

Camino had been working fine for a couple of weeks until I recently installed a 3rd party software package.  Camino randomly crashing while loading certain pages utilizing plug-ins.  Reinstalled Camino 1.0.1.  Camino worked for a while; then problem reappeared.  Camino is filing a crash log.

Reproducible: Always

Steps to Reproduce:
1.Open Camino 1.0.1
2.Go to www.morninstar.com
3.Watch Camino crash

Actual Results:  
Camino crashes

Expected Results:  
loaded page

Will attach crash log after bug is filed.
morningstar.com WFM using Camino 1.0.1 and Camino 1.0+ (2006051901).

Which "3rd party software package" did you install? What plugins are causing an issue? Is there a specific page on morningstar.com that causes this? Also, have you tried a new profile to see if that fixes the problem?
(Reporter)

Comment 2

12 years ago
Created attachment 222898 [details]
Camino Crash Log

I have also tried permission repairs to no avail.
Attachment #222898 - Attachment mime type: application/octet-stream → text/plain
(Reporter)

Comment 3

12 years ago
> Which "3rd party software package" did you install? 

TestGen.  It's a test generating software from Pearsons Educucation.  Could just be a coincidence.

> What plugins are causing an
> issue? 

I think it would be java, but I'm quite ignorant about that stuff.  I just know that Cammino seems to crash when I go to websites that require animation or some other "extra" feature other than text and pictures, and the crash log seems to be filled with the word "plugin".

> Is there a specific page on morningstar.com that causes this? 

The homepage.

> Also, have
> you tried a new profile to see if that fixes the problem?

I had not, but I just did after receiving your e-mail, and there seems to be *no* problems with Camino when I use it from a newly created account.  What does this mean, oh gurus?  When I reinstalled Camino previously (when I first started having the problem), I deleted the Camino preference file and the Camino applicaions support folder before reinstalling, but that didn't seem to help.

Thank you all for your time.  It seems that since Camino worked in a new account, that this isn't a Camino problem, but a problem with my machine.  If it is, I apologize and nonetheless appreciate your help figuring out the problem.
(Reporter)

Comment 4

12 years ago
I forgot to add that the last time I had a similar problem with Camino (a couple fo months ago), re-installing the system software seemed to do the trick, but that seems like a brute solution, and I'm hoping to find another way of dealing with this (as well as finding the root problem so it doesn't *keep* happening).
For reference, the previous bug was bug 329029.

Seamus, what version of Flash do you have installed?  Also, what is the SMART status of your hard disk (in Disk Utility)?  The only things that seem to make any sense as possible causes are a bad Flash plugin, a dying disk, or something else on your Mac that is repeatedly corrupting key files....

Comment 6

11 years ago
Seamus, could you respond to comment 5?
Whiteboard: [CLOSEME 6/18]
(Reporter)

Comment 7

11 years ago
(In reply to comment #6)
> Seamus, could you respond to comment 5?
> 

Sorry.  It seems that I do have some problem that causes corruption of files.  I had the most recent version of flash, shockwave, etc, and I had recently reinstalled system software due to file corruption.  Shortly after Comment 5 was posted, I noticed that one of my external drives needed repair in the directory system, and it was accompanied by massive permissions repairs on the internal drive.  I'm not quite sure what is happening, but when I reinstalled the system software again and reinstalled camino, it seemed to function OK.  SMART status is currently verified, and Camino is running well. . . for now.  My only guess is that Camino is the first thing to go when the corruption reaches a high enough level to noticibly effect software problems.  I had this problem before, but thought that it might have been Camino, since after the system install Camino started crashing again.  Perhaps is was Camino somehow currpting the files.  But now that I've had to reinstall the sys software again, there seems to be something more systemic causeing the problem.  I just had my internal drive replaced a couple of months ago, so I really have no idea what's going on.  I think it might be a file-sharing system I have that causes the corruption.  I'm not certain though.  Things are still a mystery.

Comment 8

11 years ago
Closing WFM on behalf of the reporter.  Seamus, if Camino starts crashing again, feel free to reopen this, but it sounds like the problem was being caused by something else.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
Whiteboard: [CLOSEME 6/18]

Updated

11 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.