Unicode text changes characters when next to selection

RESOLVED WORKSFORME

Status

()

Core
Graphics
RESOLVED WORKSFORME
12 years ago
9 years ago

People

(Reporter: ignazvonstraubing+bugzilla, Unassigned)

Tracking

Trunk
x86
Windows Server 2003
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: cairo, URL)

Attachments

(3 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9a1) Gecko/20060519 Minefield/3.0a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9a1) Gecko/20060519 Minefield/3.0a1

When selecting Unicode in various Wikipedia articles, text adjacent to the selection will disappear or change characters. The problems are most easily observed if the text size is increased, but are quite noticable without doing so.

In addition to the steps to reproduce, see http://img134.imageshack.us/img134/6466/untitled13gw.gif , which shows screen captures of the problem being manifested.

Reproducible: Always

Steps to Reproduce:
For 'scythe' article
1. Using the URL provided in the summary, select the 'α', stopping at the right edge of the character
2. Note that the 'ɪ' suddenly pops into existence, rather than being rendered as a block
3. Extend selection to include 'ɪ' and notice it reverts to original appearance

For Kali Yuga article
1. Select 'Devnagari'
2. The remaining parenthesised text to the left of the selection disappears
3. Extend selection to character in Devnagari text, and it will pop back into existence
Actual Results:  
Selecting text adjacent to Unicode changes the rendering

Expected Results:  
Selection should have no effect on the rendered text
Not sure what you mean, as I see no difference before & after the selection, but it might be a cairo thing.
Component: General → GFX: Thebes
Product: Firefox → Core
QA Contact: general → thebes
Whiteboard: cairo
Version: unspecified → Trunk

Updated

12 years ago
Depends on: 340590

Updated

12 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

11 years ago
Created attachment 261650 [details]
minor problem on FF2

This attachment is a GIMP image with layers demonstrating a minor problem on Firefox 2; turn on/off the top layer to see that that the "hat" on the last character ī is shorter by a few pixels when the selection changes.

I cant see problems of the extent shown in http://img134.imageshack.us/img134/6466/untitled13gw.gif

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

Comment 3

11 years ago
Created attachment 261651 [details]
as above; layer 1

Comment 4

11 years ago
Created attachment 261652 [details]
as above; layer 2
Can you reproduce with a recent nightly ?
This looks like a possible duplicate of (fixed) (later) bug 369276...

Comment 6

9 years ago
(In reply to comment #5)
> Can you reproduce with a recent nightly ?
> This looks like a possible duplicate of (fixed) (later) bug 369276...

I'm not able to reproduce in Fx 3.0. I'll close this out, please  re-open if you still see the issue in the latest release.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.