Text moving when selecting it

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
13 years ago
12 years ago

People

(Reporter: hafkensite, Unassigned)

Tracking

({regression})

Trunk
mozilla1.9alpha6
x86
Windows XP
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.9 +
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(2 attachments)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a2pre) Gecko/20070204 Minefield/3.0a2pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a2pre) Gecko/20070204 Minefield/3.0a2pre

When you start selecting the text (A I often do when I read it), the text sometimes moves one pixel. I think I have also seen this on a Linux computer running Firefox.

Reproducible: Always

Steps to Reproduce:
1. Go to a tweakers.net news article
2. Start selecting the text of the article (horizontaly)
Actual Results:  
The text on the current line moves 1 pixel in left or right direction

Expected Results:  
The text doesn't move, it just gets selected
I think this is a regression of Bug 333659. Tried some builds before and after and the checkin for this bug was within that time span.
I don't see a similar bug so confirming.
Status: UNCONFIRMED → NEW
Component: General → GFX: Thebes
Ever confirmed: true
Product: Firefox → Core
QA Contact: general → thebes
Version: unspecified → Trunk
Yes, it is.
Blocks: 333659
Keywords: regression
Duplicate of this bug: 369271
This works for me on Linux. However, I think it is related to justification; can you try a simple testcase like
<div style="text-align:justify;">Hello kitty Hello kitty Hello kitty Hello kitty Hello kitty Hello kitty Hello kitty Hello kitty Hello kitty Hello kitty Hello kitty Hello kitty Hello kitty Hello kitty Hello kitty Hello kitty</div>
?
Robert, that is correct. It moves, but only when I narrow my screen (and a linefeed is inserted).
Duplicate of this bug: 369790
Duplicate of this bug: 370258
Flags: blocking1.9?
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a3pre) Gecko/20070218 Minefield/3.0a3pre

(In reply to comment #6)
> Created an attachment (id=254284) [details]
> Test case from comment 4

I see the problem when using this testcase
I don't know if it's related, but there are some similar selection problems with some special unicode chars. Try to select some text for example on the following page:

data:text/html,&or;&and;&or;&and;&or;&and;blablablablablablablabla
Flags: blocking1.9? → blocking1.9+
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a3pre) Gecko/20070228 SeaMonkey/1.5a] (nightly) (W2Ksp4)

Confirming with SeaMonkey.
This WFM now using 
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a3pre) Gecko/20070305 Minefield/3.0a3pre

Probably fixed by bug 370588
Looks good here too

Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a3pre) Gecko/20070305 Minefield/3.0a3pre ID:2007030504 [cairo]
I can still reproduce this bug, I think that we need to enable the new text frame for this bug.
Problem solved here with the latest build.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → WORKSFORME
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a3pre) Gecko/20070305 SeaMonkey/1.5a] (nightly) (W2Ksp4)

Bug still there, per testcase:
Not happening if displayed on one line;
but happening if displayed on two lines, after reducing the window width.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Not entirely fixed. When you go to the URL and select the line "gelanceerd zal worden. Het ziet er daarom naar uit dat Mozilla" you see the word "er" move a tiny bit but not the rest. I can't reproduce this with the testcase however.
Posted file zipped page
Page where the bug is visible. When you select the space between "worden." and "Het" the word "er" starts to move.
Target Milestone: --- → mozilla1.9alpha6
(In reply to comment #16)
> 
> Not happening if displayed on one line;
> but happening if displayed on two lines, after reducing the window width.

(This is what comment 5 said :-|)

***

[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a5pre) Gecko/20070504 SeaMonkey/1.5a] (nightly) (W2Ksp4)

This bug seems to be WorksForMe now,
per testcase (comment 6) and per URL page (comment 17);
and I think I haven't noticed it for sometime in daily use.
This is WFM indeed now. Fixed by bug 372631 (testcase from comment 18). As I don't know what bug fixed it in the first place, resolving WORKSFORME.
Status: REOPENED → RESOLVED
Closed: 13 years ago12 years ago
Resolution: --- → WORKSFORME
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.