event dialog does not open properly

VERIFIED FIXED

Status

Calendar
Internal Components
VERIFIED FIXED
12 years ago
11 years ago

People

(Reporter: Gregg Reed, Unassigned)

Tracking

Trunk
x86
Windows 2000
Dependency tree / graph

Details

(URL)

Attachments

(1 obsolete attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1a2) Gecko/20060522 BonEcho/2.0a2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060520 Mozilla Sunbird/0.3a2+

In Sunbird builds 20060521 and 20060522, the event dialog box does not open properly.  Instead of the normal window, the box opens with just the title.  The window can be formed by grabbing an edge and expanding it.  However, there is an error associated with the start/stop time and alarm sections as shown in the attached link.

Reproducible: Always
Confirmed. Looks like it is not possible to hide the dialog items anymore.
Works in sunbird-0.3a2+.en-US.win32-2006-05-20-09-trunk build
Fails in sunbird-0.3a2+.en-US.win32-2006-05-21-09-trunk build

Errors in JavaScript console:

Error: uncaught exception: [Exception... "Illegal operation on WrappedNative prototype object"  nsresult: "0x8057000c (NS_ERROR_XPC_BAD_OP_ON_WN_PROTO)"  location: "JS frame :: chrome://calendar/content/calendar-event-dialog.js :: loadDialog :: line 254"  data: no]

Error: [Exception... "Illegal operation on WrappedNative prototype object"  nsresult: "0x8057000c (NS_ERROR_XPC_BAD_OP_ON_WN_PROTO)"  location: "JS frame :: chrome://calendar/content/calendar-event-dialog.js :: toggleDetails :: line 770"  data: no]

Error: [Exception... "Illegal operation on WrappedNative prototype object"  nsresult: "0x8057000c (NS_ERROR_XPC_BAD_OP_ON_WN_PROTO)"  location: "JS frame :: chrome://calendar/content/calendar-event-dialog.js :: toggleDetails :: line 779"  data: no]
Assignee: nobody → base
Status: UNCONFIRMED → NEW
Component: General → Base
Ever confirmed: true
OS: Windows XP → Windows 2000
QA Contact: general → base
Version: unspecified → Trunk
Confirmed on OSX build as well
-> HW/SW all/all

-> Major

I'm betting this is due to Brendan's commit of 2006-05-20 15:27 entitled "First big wave of js1.7 changes (bug 326466, bug 336376, r=mrbkap)".
Severity: normal → major
OS: Windows 2000 → All
Hardware: PC → All
(In reply to comment #2)
> I'm betting this is due to Brendan's commit of 2006-05-20 15:27 entitled "First
> big wave of js1.7 changes (bug 326466, bug 336376, r=mrbkap)".

Bug 326466 has lots of iterator changes and the jsconsole errors both point to "for each (elem in collectionOfElements)" lines

I'm investigating further, but progress is slowed by my Thinkpad crapping itself. I'm on the wife's G3 iBook at the moment.

Taking this.
Severity: major → normal
Status: NEW → ASSIGNED
OS: All → Windows 2000
Hardware: All → PC
*** Bug 339085 has been marked as a duplicate of this bug. ***
Depends on: 339169
Blocks: 335745
*** Bug 339527 has been marked as a duplicate of this bug. ***
Created attachment 223808 [details] [diff] [review]
fix using for loop

This patch fixes all the places that failed for me by using a for loop: The event dialog, the month view (if first day of week is not Sunday) and the alarm dialog (when dismissing all events). I have not experienced other for-each-loops that fail.

I have added a testcase to Bug 339169 that can be used to reproduce the error without Sunbird.
Attachment #223808 - Flags: first-review?(jminta)
Comment on attachment 223808 [details] [diff] [review]
fix using for loop

Marking patch obsolete and removing from review queue since Brendan fixed it on the JS end
Attachment #223808 - Attachment is obsolete: true
Attachment #223808 - Flags: first-review?(jminta)
-> FIXED in personal build.
Will verify once hilo makes a nightly, sometime in 2032.
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
The bugspam monkeys have struck again. They are currently chewing on default assignees for Calendar. Be afraid for your sanity!
Assignee: base → nobody

Comment 10

12 years ago
verified with
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060827 Calendar/0.3a2+
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.