Closed Bug 339083 Opened 14 years ago Closed 14 years ago

Copy/Past meeting-request stopped working

Categories

(Calendar :: General, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: marcel, Assigned: jminta)

References

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060521 Mozilla Sunbird/0.3a2+

In the previous releases, one could copy paste a meeting request from Thunderbird into sunbird. This build does not do anything after pasting the information.

Reproducible: Always

Steps to Reproduce:
1.get meeting request via email via Thunderbird
2.copy complete text in message
3.open sunbird
4.past


Actual Results:  
Nothing happens in this build.


Expected Results:  
In previous builds a new meeting was scheduled
(In reply to comment #0)
> In the previous releases, one could copy paste a meeting request from
> Thunderbird into sunbird.

What previous releases? Version? Build date? If possible specify the last working version.

> Steps to Reproduce:
> 1.get meeting request via email via Thunderbird
> 2.copy complete text in message

Please post the content of the clipboard containing the 'copy complete text in message' you are trying to paste.

> Actual Results:  
> Nothing happens in this build.

Silent fail? Or are there error messages in JavaScript console?
> What previous releases? Version? Build date? If possible specify the last
> working version.

I am using ( Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060507 Mozilla Sunbird/0.3a2 ) which works fine
The latest nightly ( Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060523 Mozilla Sunbird/0.3a2+ )also has this bug.
 
> 
> Please post the content of the clipboard containing the 'copy complete text in
> message' you are trying to paste.

Here it comes (I did change the email adresses):

BEGIN:VCALENDAR
PRODID:-//Microsoft Corporation//Outlook 11.0 MIMEDIR//EN
VERSION:2.0
METHOD:REQUEST
BEGIN:VEVENT
ATTENDEE;ROLE=REQ-PARTICIPANT;RSVP=TRUE:MAILTO:XXXXXX@XXXXX.co.za
ATTENDEE;ROLE=REQ-PARTICIPANT;RSVP=TRUE:MAILTO:XXXXXX@XXXXX.co.za
ATTENDEE;ROLE=REQ-PARTICIPANT;RSVP=TRUE:MAILTO:XXXXXX@XXXXX.co.za
ATTENDEE;ROLE=REQ-PARTICIPANT;RSVP=TRUE:MAILTO:XXXXXX@XXXXX.co.za
ORGANIZER:MAILTO:XXXXXX@XXXXX.co.za
DTSTART:20060523T080000Z
DTEND:20060523T090000Z
LOCATION:BDS Offices
TRANSP:OPAQUE
SEQUENCE:1
UID:040000008200E00074C5B7101A82E00800000000A0AE3450397BC6010000000000000000100
 00000B3E6AFF42E84F64389279BDD86DEAD40
DTSTAMP:20060522T061126Z
DESCRIPTION:When: 23 May 2006 10:00-11:00 (GMT+02:00) Harare\,
  Pretoria.\nWhere: BDS Offices\n\n*~*~*~*~*~*~*~*~*~*\n\n\n
SUMMARY:Updated: Meeting to discuss way forward approach schools for
  installation of Computers
PRIORITY:5
X-MICROSOFT-CDO-IMPORTANCE:1
CLASS:PUBLIC
BEGIN:VALARM
TRIGGER:-PT30M
ACTION:DISPLAY
DESCRIPTION:Reminder
END:VALARM
END:VEVENT
END:VCALENDAR


> Silent fail? Or are there error messages in JavaScript console?

Yes, no error message, no nothing...
(In reply to comment #2)

Your example works for me. Same behavior in Sunbird 0.3a2 and in latest nightly build. I perform the paste and the event shows up on the selected day.

A second paste will fail because there already exist an event with the same UID (the one added before) in database now. In that case I see the following error message:

  Error: Severe error in internal transaction code! ID already
  exists for addItem. Please report this to the developers.
  Source File: chrome://calendar/content/calendar-item-editing.js Line: 294

If I remove the UID from your example I can paste the event as often as I want.

You said before you don't see any errors so this is not related to your problem.
Downloaded the latest version (30 may) and got the following error when trying to copy/paste

Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [calIDateTime.isDate]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://calendar/content/clipboard.js :: pasteFromClipboard :: line 259"  data: no]
Attached patch clone dateSplinter Review
Clone the firstDate, since some views return immutable dates.
Assignee: nobody → jminta
Status: UNCONFIRMED → ASSIGNED
Attachment #224631 - Flags: first-review?(mvl)
Summary: Copy/Past meetig-request stoped working → Copy/Past meeting-request stopped working
Comment on attachment 224631 [details] [diff] [review]
clone date

r=mvl
Attachment #224631 - Flags: first-review?(mvl) → first-review+
Patch checked in.
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
*** Bug 341992 has been marked as a duplicate of this bug. ***
REOPEN

when try to paste event from comment 2
first time works fine
second time got error from comment 3 but not from comment 4
third and more following error similar to comment 4

Error: uncaught exception: [Exception... "Component returned failure code: 0x804a0107 [calIICSService.parseICS]"  nsresult: "0x804a0107 (<unknown>)"  location: "JS frame :: chrome://calendar/content/clipboard.js :: pasteFromClipboard :: line 218"  data: no]

not sure what exacly did you fix but errors still occurs

and even if I delete all events could not paste it anymore - looks like this event is stored somewhere...
(In reply to comment #9)
> when try to paste event from comment 2 first time works fine

This means the problem is fixed.

> second time got error from comment 3 but not from comment 4

See my comment on this: A second paste will fail because there already exist an event with the same UID (the one added before) in database now.

Maybe there should be a follow up bug to fix that issue, e.g. by always setting a new UID on the item pasted from clipboard.
(In reply to comment #10)
> This means the problem is fixed.
ok, so please verify this issue

> > second time got error from comment 3 but not from comment 4
> See my comment on this: A second paste will fail because there already exist an
> event with the same UID (the one added before) in database now.
Sorry, it was not clear for me that's why I wrote it to help you to decide if this is fixed whether not - it's better than just verify if I'm not sure, right?
(In reply to comment #10)
> (In reply to comment #9)
> > when try to paste event from comment 2 first time works fine
> 
> This means the problem is fixed.

verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.