Closed Bug 341992 Opened 18 years ago Closed 18 years ago

Copy and paste does not work anymore

Categories

(Calendar :: General, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 339083

People

(Reporter: Peter.Meier998, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060618 Sunbird/0.3a2+

Copy and paste of an event does not work anymore.
If you want to copy and paste an event in multiday view, you do not get an new event. In the old version of sunbird you get a copy of the event.

Reproducible: Always

Steps to Reproduce:
1. Select an event
2. Press ctrl-C to copy the event
3. Press ctrl-P to paste the event



Actual Results:  
Nothing happend. No copy.

Expected Results:  
I expect the same behaviour as in the old version (see Additional Information).
You get the same event a second time. Now you are able to move the event to a different time, ...

I have an old version of sunbird aswell.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060507 Mozilla Sunbird/0.3a2

In this version copy and paste of event is working fine.
Sorry guys, just find a spelling mistake.
It should be Ctrl-V instead of Ctrl-P for shure.

The problem occures aswell, if you use the menu entries.


(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.0.4)
> Gecko/20060508 Firefox/1.5.0.4
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1)
> Gecko/20060618 Sunbird/0.3a2+
> 
> Copy and paste of an event does not work anymore.
> If you want to copy and paste an event in multiday view, you do not get an new
> event. In the old version of sunbird you get a copy of the event.
> 
> Reproducible: Always
> 
> Steps to Reproduce:
> 1. Select an event
> 2. Press ctrl-C to copy the event
> 3. Press ctrl-P to paste the event
> 
> 
> 
> Actual Results:  
> Nothing happend. No copy.
> 
> Expected Results:  
> I expect the same behaviour as in the old version (see Additional Information).
> You get the same event a second time. Now you are able to move the event to a
> different time, ...
> 
> I have an old version of sunbird aswell.
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060507
> Mozilla Sunbird/0.3a2
> 
> In this version copy and paste of event is working fine.
> 

Are there any errors in the Javascript console (aka Error Console)?
Yep:

Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [calIDateTime.isDate]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://calendar/content/clipboard.js :: pasteFromClipboard :: line 259"  data: no]
OK, I just landed a fix for that 5 minutes ago.  Should be all set in tomorrow's build.

*** This bug has been marked as a duplicate of 339083 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Thank you very much.

I saw the other post, but I couldn't link them together ;-)

Regards
   Peter


(In reply to comment #4)
> OK, I just landed a fix for that 5 minutes ago.  Should be all set in
> tomorrow's build.
> 
> *** This bug has been marked as a duplicate of 339083 ***
> 

this is very simple test so it works

but bug 339083 has something more and need to be improved

verified with
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060824 Calendar/0.3a2+
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.