Closed Bug 339099 Opened 15 years ago Closed 15 years ago

Integrate extensions/cookie and extensions/permissions into libxul

Categories

(Toolkit Graveyard :: Build Config, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
mozilla1.9alpha1

People

(Reporter: benjamin, Assigned: benjamin)

References

Details

Attachments

(1 file)

"cookie" and "permissions" are really toolkit-level services and should be in libxul.
Attachment #223173 - Flags: first-review?(darin)
I think these should eventually move into toolkit/, but for now this solution seems reasonable.
Comment on attachment 223173 [details] [diff] [review]
With a MOZ_PERMISSIONS switch, rev. 1

>Index: configure.in

> dnl ========================================================
>+dnl Permissions Backend
>+dnl ========================================================
>+MOZ_ARG_DISABLE_BOOL(permissions,
>+[  --disable-permissions   Disable permissions (popup and cookie blocking)],
>+    MOZ_PERMISSIONS=,
>+    MOZ_PERMISSIONS=1
>+)

This is more than just the permissions backend, right?  Maybe the
"Permissions System"

I wish we had a better name for this other than permissions.  Reading
"--disable-permissions" doesn't really tell me much about what it does.
That said, I can't think of anything better.


r=darin
Attachment #223173 - Flags: first-review?(darin) → first-review+
Fixed on trunk.
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
I wonder if this caused Bug #339410 in Thunderbird. Remote images stopped displaying in builds from the 26th of May.

It looks like we are now building the permissions extension which we weren't building before as a result of this change. I think it is replacing Thunderbird's permission manager for remote content. I'll keep digging. 

Blocks: 339410
Indeed this build change is the cause. This new content policy manager from the permissions directory is getting the last say on whether a url should be loaded even if thunderbird's content policy manager allows the load.
If xulrunner is to carry this code (and that seems like a reasonable idea), then we need a pref to disable it.  That way tbird can set that pref appropriately.
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.