Thunderbird forgets saved mail password when it gets a login failure on server

RESOLVED DUPLICATE of bug 121647

Status

Thunderbird
General
--
minor
RESOLVED DUPLICATE of bug 121647
12 years ago
10 years ago

People

(Reporter: Baldur Gislason, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.8) Gecko/20051213 Firefox/1.5
Build Identifier: Mozilla Thunderbird version 1.0.7 (20051213)

I'm accessing a Microsoft IMAP server at work, and every so often the mail server crashes and starts rejecting logins. When this happens, Thunderbird forgets the saved mail password and I have to type it in again.

Reproducible: Always

Steps to Reproduce:
1.Configure mail account with saved password
2.Change password on server or otherwise break mail server authentication.
3.Have to type in password on every single attempt to reconnect to mailserver.

Actual Results:  
The "remember password" checkbox becomes unchecked and the input box will be blank every time the mail server password dialog pops up.

Expected Results:  
Preferred behavior would be to let the dialog pop up if there is a problem logging in but have the input box populated and the "remember-password" checkbox checked so that the only course of action needed to retry is to press OK.

This happens on all versions of Thunderbird I have set up on any of the computers I use on a day to day basis.

Comment 1

12 years ago
Please try thunderbird 1.5 or later, 1.0.7 is coming of age... Also, further improvements for this was made in bug 249240, so you might also want to try latest branch builds if 1.5 hasn't fixed it for you.

Comment 2

12 years ago
Make that trunk builds, it's not on branch yet.

Comment 3

11 years ago
I've got the same problem, but it isn't a Microsoft IAMP, it's a (unknown) IAMP at 1und1.de. Thunderbird 1.5.0.9 (20061207), Windows 2000 prof.

When 1und1 isn't reachable (for some reasons) or has some other problems with it's mailserver my TB is very nervous and shows many many popups (because I've got about 10 or more email-adresse, all IMAP). I can't remember all my passwords, so I've got to look up every single password and retype it, and then again the popup nerves, because 1und1 has still a problem.

TB should show a problem in "Can't login", but don't have to nerve with passwords to retype which are saved correctly in password-manager. Just show a status, but don't use such many popups.

To change my password I'd like to go to the password-manager and do it there (and only there), I don't need a popup to change it (simply because I do not wont to change it and it's saved correctly at the password-mnager, the problem is at the server).

Comment 4

11 years ago
AAAARGGHHH! Now it happened again! Thunderbird used a temporary server error as an excuse to throw away the password data I have told it to store. Still no fix? (version 2.0.0.4)

Updated

10 years ago
Duplicate of this bug: 430092

Comment 6

10 years ago
Thunderbird version 2.0.0.12 (20080213) on Windows XP, same thing as Baldur's Bug. Very annoying since I use obscure passwords.

Same sentiments as Dennis, need a server fail detection to show an account as temporarily out-of-touch. Apple Mail uses little lightening rods to show this (but  makes the user re-activate them which is poor).

After losing my password I re-typed it in and the server was fine. (Google) Could be a net glitch, or server overload that caused it but either way dropping the saved password is the wrong result for the situation.

Comment 7

10 years ago
Additional: This bug is reported for FreeBSD, The duplicate above was reported for Mac OS X. I have the problem on Windows XP. It is clearly a platform independent bug.

Comment 8

10 years ago
This sounds like bug 121647.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
OS: FreeBSD → All
Hardware: PC → All
Resolution: --- → DUPLICATE
Duplicate of bug: 121647
You need to log in before you can comment on or make changes to this bug.