Multiple sheets (dialog boxes) on one window results in blank sheets and hang

RESOLVED DUPLICATE of bug 337646

Status

Core Graveyard
Widget: Mac
--
critical
RESOLVED DUPLICATE of bug 337646
12 years ago
9 years ago

People

(Reporter: Patrick, Assigned: Josh Aas)

Tracking

({hang, regression})

Trunk
PowerPC
Mac OS X
hang, regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
[See also bug 312586 comment 14 and bug 337334 comment 17 up and until 19]

1. Clean profile. Create a user.js file that says
user_pref("network.cookie.cookieBehavior", 3);
user_pref("network.cookie.lifetimePolicy", 1);
user_pref("network.cookie.p3p", "frfradaa");
user_pref("network.cookie.p3plevel", 2);

--> this way you'll get a dialog whether or not you want to accept a cookie
that is being offered.

2. Define a bookmark consisting a bunch of pages to open up as a tab.

3. Open all these pages at the same time via OPEN IN TABS. Since this is a clean profile you're likely to be bombarded with "sheets" (aka dialogs) for accepting the cookies from all these pages. After acknowledging the second cookie, the third sheet will be completely blank. This effectively results in a hang as it seems not possible to dismiss the sheet.


Regression range unclear, this happens with
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20060524
Minefield/3.0a1

but also with 
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20060504 Minefield/3.0a1

which was the oldest trunk build i could find on ftp.mozilla.org

17" Powerbook G4, latest version before inclusion of iSight [Rev D?]
(Reporter)

Comment 1

12 years ago
Seeing similar symptoms with TB branch. --> remove an account (eg RSS&BLOGS) from the account manager and OK your way out of the dialogs/sheet.

A final blank sheet is thrown, hanging the app.
--> If someone can confirm the last bit, this bug should be moved from trunk to trunk & branch.

Comment 2

12 years ago
Duplicate of bug 337646?
(Reporter)

Comment 3

12 years ago
(In reply to comment #2)
> Duplicate of bug 337646?
> 

Good question. They have certainly have the blank sheet in common, but the method for triggering seems quite different

Comment 4

12 years ago
Hmm.  You say that you see the regression on the trunk as early as 0504, and the possible dupe says that it's on the branch beginning 050909.  Let's nail down the trunk regression range for your particular steps to reproduce a little bit more clearly.  You can pick up builds that have been pruned from the main download site at archive.mozilla.org:

http://archive.mozilla.org/pub/mozilla.org/firefox/nightly/

Comment 5

12 years ago
Mine.  This is a slightly timing-sensitive variant of bug 337646.  A patch will appear over there shortly.

*** This bug has been marked as a duplicate of 337646 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Comment 6

12 years ago
*** Bug 339683 has been marked as a duplicate of this bug. ***

Updated

9 years ago
Component: Widget: Mac → Widget: Mac
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.