[CRASH] Mozilla crashes on starting a download.

VERIFIED DUPLICATE of bug 46266

Status

()

Core
JavaScript Engine
P3
blocker
VERIFIED DUPLICATE of bug 46266
18 years ago
16 years ago

People

(Reporter: Jason Eager, Assigned: rogerl (gone))

Tracking

({crash, topcrash})

Trunk
x86
Linux
crash, topcrash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
This is from my build from the CVS last night,
I went to download the new opera tech-preview, and
the download progress window appeared, I downloaded
1 KB of 2173 or whatever, and then the whole browser
crashed.

It did the same thing to me when I tried to download a
nightly build.

Comment 1

18 years ago
Attaching a backtrace, taken on Debian GNU/Linux PowerPC(potato).

Comment 2

18 years ago
Created attachment 7103 [details]
backtrace of the crash

Comment 3

18 years ago
Created attachment 7106 [details] [diff] [review]
Another backtrace I get from this - see comments

Comment 4

18 years ago
I see two different traces when following these directions (for opera),
depenging in some way on the path I pick to save it into. I can't figure out the
pattern though - it seems to crash on memory allocation both times, but export
MALLOC_CHECK_=2 didn't pick up anything...

Comment 5

18 years ago
sorry roger!
Assignee: cbegle → rogerl
Component: Browser-General → Javascript Engine
QA Contact: asadotzler → rginda

Comment 6

18 years ago
I've noticed that when I try to save a file to a directory that I cannot write
into, Mozilla complains about an unknown error.   One of two things happen: if
I've successfully saved somewhere else (that is, by specifying a different path,
which I can write into) before, another complaint about an unknown error is
presented and the download aborts.  If I have *not* saved somewhere before, the
entire browser dies, with the text "Error closing dialog" followed by
'./run-mozilla.sh: line 29: 10665 Segmentation fault   $prog ${1+"@"}'
This is with M15/Linux, with full-circle.

Comment 7

18 years ago
Adding crash keyword.
Keywords: crash

Comment 8

18 years ago
*** Bug 37037 has been marked as a duplicate of this bug. ***

Comment 9

18 years ago
Not sure if this is the same but I crash when I go to http://

shareware.netscape.com/computing/shareware/download.tmpl?p=PC&category_id=78&

subcategory_id=94&id=33943 and click the download link.  I never see the dialog 

box, moz crashes on click.  This is with the commercial build, 2000071910.  I 

have a few talkbacks sent, but i don't remember how to get their numbers.  This 

is on 98.

Comment 10

18 years ago
talkback ID's TB14514839G & TB14515280X

Comment 11

18 years ago

*** This bug has been marked as a duplicate of 46266 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 12

18 years ago
Adding topcrash keyword.
Keywords: topcrash

Comment 13

17 years ago
Verified dupe.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.