Closed Bug 339639 Opened 14 years ago Closed 14 years ago

Rename month-view's css classes.

Categories

(Calendar :: Internal Components, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: jminta, Assigned: mattwillis)

Details

Attachments

(1 file)

Within calendar-month-view.xml we currently have calendar-month-day-box-even and calendar-month-day-box-odd classes.  Rather than actually corresponding to even and odd days, they are actually used for days off and workweek days.  We should rename them so that the names correspond with their functions.
They do? What does "calendar-month-day-box-weekend" correspond to then?


calendar-month-day-box { 
  border: 1px solid #3F7D91;
  overflow-x: hidden;
  overflow-y: auto;
}

.calendar-month-day-box-even {
  background: #FFFFFF;
}

.calendar-month-day-box-weekend {
  background: #FFF9E7;
}

.calendar-month-day-box-odd {
  background: #E7EEEC;
}

.calendar-month-day-box-even[today="true"],
.calendar-month-day-box-weekend[today="true"],
.calendar-month-day-box-odd[today="true"] {
  background: #dfeaf4;
  border: 2px solid #1D7AB5 !important;
}

.calendar-month-day-box-even[selected="true"],
.calendar-month-day-box-weekend[selected="true"],
.calendar-month-day-box-odd[selected="true"] {
  background: #ffe79c;
  border: 1px solid #1D7AB5;
}
Ok. Figured this out:

calendar-month-day-box-weekend = "days off"
calendar-month-day-box-odd = "days not in the currently selected month"
calendar-month-day-box-even = "days in the currently selected month"

What selectors should we use instead?
Since length apparently doesn't seem to be an issue ;) how about:
calendar-month-day-box-dayOff
calendar-month-day-box-otherMonth
calendar-month-day-box-thisMonth

or should these use the [selected="true"] thing instead?
(In reply to comment #2)
> What selectors should we use instead?
> Since length apparently doesn't seem to be an issue ;) how about:
> calendar-month-day-box-dayOff
> calendar-month-day-box-otherMonth
> calendar-month-day-box-thisMonth
currentMonth instead of thisMonth seems better to me, but otherwise it looks fine.

> 
> or should these use the [selected="true"] thing instead?
> 
I think some themes might want to make otherMonth days ahve slightly different selection colors than currentMonth selection, and that's their choice.  Therefore, I think it's cleaner to use the classes.  Selectors seem more mutable too.
Assignee: base → mattwillis
Status: NEW → ASSIGNED
Attachment #225716 - Flags: first-review?(jminta)
Comment on attachment 225716 [details] [diff] [review]
rev0 - changes css selector names per irc discussion with jminta

r=jminta
Attachment #225716 - Flags: first-review?(jminta) → first-review+
Patch checked in on MOZILLA_1_8_BRANCH and trunk.

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.