Locale repackaging to support the NSIS installer

RESOLVED FIXED in Firefox 2 beta1

Status

()

Firefox
Installer
P1
normal
RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: rstrong, Assigned: Benjamin Smedberg)

Tracking

({fixed1.8.1})

2.0 Branch
Firefox 2 beta1
x86
Windows XP
fixed1.8.1
Points:
---
Dependency tree / graph
Bug Flags:
blocking-firefox2 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: 181b1+)

Attachments

(5 attachments, 1 obsolete attachment)

The build scripts will need to be updated to support locale repackaging for the NSIS installer implemented in bug 326580.
(Assignee)

Updated

12 years ago
Assignee: nobody → benjamin
Priority: -- → P1
Target Milestone: --- → Firefox 2 beta1
(Assignee)

Updated

12 years ago
Depends on: 340864
No longer blocks: 339183
(Assignee)

Updated

12 years ago
Flags: blocking-firefox2+

Updated

12 years ago
Depends on: 340173
(Assignee)

Comment 1

12 years ago
Created attachment 227268 [details] [diff] [review]
Make setup.exe generation separate, rev. 1

This is a prerequisite small patch which separates out the building of setup.exe into a separate target from that which builds the entire installer.
Attachment #227268 - Flags: review?(robert.bugzilla)
Attachment #227268 - Flags: review?(robert.bugzilla) → review+
(Assignee)

Comment 2

12 years ago
Created attachment 227315 [details] [diff] [review]
Repack it!, rev. 1

Woot!
Attachment #227315 - Flags: review?(robert.bugzilla)
Checked in browser/installer/windows/Makefile.in change to calendar/installer/windows/Makefile.in also

Reminder to bsmedberg per IRC discussion to land this on branch eventually, as calendar's NSIS stuff is also on branch at this time.

Comment 4

12 years ago
I wonder what we do about README.txt, which I recall not being in localized, 
and where do the spellcheck dictionaries end up right now?
I guess for now, we would like to keep the en-US dict in there, but that's likely an offline discussion.

Those comments without a windows env, so I haven't applied and tested the patch.
(In reply to comment #4)
> I wonder what we do about README.txt, which I recall not being in localized

Unless I'm looking at the wrong thing, README.txt is localized (although the filename itself is not.)

http://lxr.mozilla.org/mozilla/source/browser/locales/en-US/README.txt
> Created an attachment (id=227268) [edit]
> Make setup.exe generation separate, rev. 1

With this checkin, I'm now getting errors when building the installer because ABS_CONFIG_DIR is empty, so 7zip is trying to put the app in /app.7zs. 

I'm seeing "/bin/sh: line 0: cd: instgen: No such file or directory" when the $shell command that sets ABS_CONFIG_DIR executes in toolkit/mozapps/installer/windows/nsis/makensis.mk

Updated

12 years ago
Whiteboard: 181b1+
Created attachment 227347 [details] [diff] [review]
patch to fix regression

patch by bsmedberg, r=lilmatt
Attachment #227347 - Flags: review+
(In reply to comment #7)
> Created an attachment (id=227347) [edit]
> patch to fix regression

Patch checked in on _trunk_only_.

Comment 9

12 years ago
filed bug 342938 on the README.txt issue.
We add it to the localized files at 
http://lxr.mozilla.org/mozilla1.8/source/browser/locales/Makefile.in#90 as
part of the libs target.
Comment on attachment 227315 [details] [diff] [review]
Repack it!, rev. 1

very nice
Attachment #227315 - Flags: review?(robert.bugzilla) → review+
Created attachment 227390 [details] [diff] [review]
patch for calendar

Changes needed for calendar
Attachment #227390 - Flags: review?(mattwillis)
> Created an attachment (id=227390) [edit]
> patch for calendar

-	cp $(topsrcdir)/calendar/EULA.txt instgen/license.txt
+	cp $(topsrcdir)/browser/EULA $(CONFIG_DIR)/license.txt

Um, no.


-#ifdef MOZ_SUNBIRD
-APP_VERSION = $(SUNBIRD_VERSION)
-DEFINES += -DAPP_VERSION="$(APP_VERSION)"
-#endif
+APP_VERSION := $(shell cat $(srcdir)/../config/version.txt)

Is this necessary for the patch to work? We've been on a mission to use $SUNBIRD_VERSION rather than catting version.txt everywhere. 


 DEFINES += \
-    -DAB_CD=$(AB_CD) \
-    -DMOZ_LANGPACK_EID=langpack-$(AB_CD)@sunbird.mozilla.org \
-    -DMOZ_APP_VERSION=$(MOZ_APP_VERSION) \
-    -DLOCALE_SRCDIR=$(LOCALE_SRCDIR) \
-    -DPKG_BASENAME=$(PKG_BASENAME) \
-    $(NULL)
+	-DAB_CD=$(AB_CD) \
+	-DMOZ_LANGPACK_EID=langpack-$(AB_CD)@sunbird.mozilla.org \
+	-DMOZ_APP_VERSION=$(MOZ_APP_VERSION) \
+	-DLOCALE_SRCDIR=$(LOCALE_SRCDIR) \
+	-DPKG_BASENAME=$(PKG_BASENAME) \
+	$(NULL)

Pull this bit so as to not hose CVS blame. Besides, you only NEED tabs inside the makefile targets :)
(Assignee)

Comment 13

12 years ago
Created attachment 227440 [details] [diff] [review]
Fix branding, rev. 1
Attachment #227440 - Flags: review?(l10n)
Comment on attachment 227390 [details] [diff] [review]
patch for calendar

Opened bug 343024 for Calendar
Attachment #227390 - Attachment is obsolete: true
Attachment #227390 - Flags: review?(mattwillis)

Comment 15

12 years ago
Comment on attachment 227440 [details] [diff] [review]
Fix branding, rev. 1

looks good to me, and makes sense with the error log we have for ga-IE, too.
Attachment #227440 - Flags: review?(l10n) → review+

Comment 16

12 years ago
To verify that this is fixed, we actually need nsis on the tinderboxens, filed bug
343055.
Depends on: 343055
(Assignee)

Comment 17

12 years ago
Created attachment 227577 [details] [diff] [review]
1.8 branch merge, rev. 1
Attachment #227577 - Flags: approval1.8.1?
Comment on attachment 227577 [details] [diff] [review]
1.8 branch merge, rev. 1

approved as per 181drivers
Attachment #227577 - Flags: approval1.8.1? → approval1.8.1+
Whiteboard: 181b1+ → 181b1+ [checkin needed]
(Assignee)

Comment 19

12 years ago
Woot, trunk and 1.8
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED
Whiteboard: 181b1+ [checkin needed] → 181b1+
You need to log in before you can comment on or make changes to this bug.