Closed Bug 339863 Opened 15 years ago Closed 15 years ago

Scriptable SVG interfaces inherit from non-scriptable interfaces

Categories

(Core :: SVG, defect)

1.8 Branch
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: jhpedemonte, Unassigned)

References

Details

(Keywords: fixed1.8.1)

Attachments

(1 file)

Warnings while working on the 1.8 branch:

----------------------
nsISVGGlyphGeometrySource.idl:100: Warning: nsISVGGlyphGeometrySource is scriptable but inherits from the non-scriptable interface nsISVGGlyphMetricsSource

nsISVGPathGeometrySource.idl:114: Warning: nsISVGPathGeometrySource is scriptable but inherits from the non-scriptable interface nsISVGGeometrySource
----------------------

It seems that nsISVGGlyphGeometrySource was made non-scriptable on the trunk.  Same with nsISVGPathGeometrySource.  Perhaps we can do that on the branch also?
Attached patch patchSplinter Review
Talked to Tim, who said to just mark all of the interfaces in renderer/public as non-scriptable.
Attachment #223975 - Flags: review?(tor)
Attachment #223975 - Flags: review?(tor) → review+
Attachment #223975 - Flags: approval-branch-1.8.1?(tor)
Attachment #223975 - Flags: approval-branch-1.8.1?(tor) → approval-branch-1.8.1+
Checked in to 1.8 branch. ->FIXED
Status: NEW → RESOLVED
Closed: 15 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED
*** Bug 350071 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.