Closed Bug 339970 Opened 15 years ago Closed 15 years ago

Comma within quotation marks (') messes up e-mail address parsing

Categories

(Thunderbird :: Mail Window Front End, defect)

x86
Windows 2000
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 254519

People

(Reporter: gyuri, Assigned: mscott)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3
Build Identifier: version 1.5.0.2 (20060308)

If any of the recipients of an e-mail has an e-mail address like 'x, y' <z@u.i.dd> then the address is split at the comma. This happens both in the main window and when trying to reply to the e-mail. The result is an incorrect e-mail address, and the e-mail cannot be delivered. The error does not occur if the quotation mark " is used instead of '.

Reproducible: Always

Steps to Reproduce:
1. Receive an e-mail as described above.
2.
3.

Actual Results:  
The address appears as two addresses.

Expected Results:  
The address should appear as one single address.
Since you haven't provided any data we can look at, I'm going to have to guess, but I bet this is a dupe of bug 254519.
(In reply to comment #1)
> Since you haven't provided any data we can look at, I'm going to have to guess,
> but I bet this is a dupe of bug 254519.
> 

I checked and it is indeed. 

*** This bug has been marked as a duplicate of 254519 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.