Clicking link in message opens in current IE window

RESOLVED DUPLICATE of bug 222021

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 222021
12 years ago
9 years ago

People

(Reporter: scanomatic, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 2.0.50727; .NET CLR 1.1.4322)
Build Identifier: version 1.5.0.4 (20060516)

Clicking link in message window opens in a CURRENT IE window, instead of a new one. This causes users to unwantedly leave web pages, often losing form data. Seems to work on any web link. IE 6. Have not tried FireFox.

Reproducible: Always

Steps to Reproduce:
1. Make sure IE is your browser
2. Open IE, go to any web page.
3. Go back to Thunderbird, click link in a message.

Actual Results:  
Go off from web site I loaded in step #2. CAN CAUSE YOU TO LOSE DATA ENTERED IN FORM

Expected Results:  
Software should've opened NEW browser window instead, and loading web page in that.

Updated

9 years ago
Assignee: mscott → nobody
Doesn't seem to be a Thunderbird issue.

Thoughts?

Comment 2

9 years ago
This is a top pia. It is standard for me to press SHIFT-click or CTRL-click on a hyper-link in Eudora or IE to force the opening of a NEW IE window. Doing so in Thunderbird is ignored. Just clicking the link causes already opened IE windows to be destroyed.
IIRC IE7 has an option to open new links in a new window/tab, but I don't think IE6 has that. In fact, most recent browsers have this option AFAIK.

I'm advocating an Invalid from a TB POV because this works as expected if the relevant browser setting is set correctly, but would like to welcome a second opinion.

Comment 4

9 years ago
IMHO TB should behave identically with other applications when a hyperlink is clicked, shift-clicked or ctrl-clicked. It doesn't. FYI, IE6 does have a RT click option to open links in a new window and the same can be achieved with shift-click, not that that is really relevant to this issue. As the OP said, if you happen to have form data prepared in an IE window it can be destroyed if you accidently click a link in a TB message. There is no option\setting I can find to prevent this from happening or to enable the link to open in a new window.
(In reply to comment #4)
> IMHO TB should behave identically with other applications when a hyperlink is
> clicked, shift-clicked or ctrl-clicked. It doesn't. FYI, IE6 does have a RT
> click option to open links in a new window and the same can be achieved with
> shift-click, not that that is really relevant to this issue. As the OP said, if
> you happen to have form data prepared in an IE window it can be destroyed if
> you accidently click a link in a TB message. There is no option\setting I can
> find to prevent this from happening or to enable the link to open in a new
> window.

I see, thanks for the clarification, in that case this bug is a dupe of bug 222021. Duping.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 222021
You need to log in before you can comment on or make changes to this bug.