View Source on secure page makes new request, rather than showing the source used to render the page

RESOLVED DUPLICATE of bug 307089

Status

()

Toolkit
View Source
RESOLVED DUPLICATE of bug 307089
12 years ago
4 years ago

People

(Reporter: James Hardy, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3

View Source on secure page makes new request, rather than showing the source used to render the page. 

This bug has caused be some problems for me when checking that affiliate tracking pixel-images have been set correctly as the session data used to generate the image urls is cleared after the pixel is generated. Then when viewing source it appears to have generated the wrong URL (ie the data is missing)

I suspect that this is because it (correctly) does not cache secure pages, but there should be some way


Reproducible: Always

Steps to Reproduce:
Create a page on a server that increments a session variable each time it is requested.

A sample (in ASP3.0/VBScript) would be:
<%
if session("counter")="" then session("counter")=0
session("counter")=session("counter")+1
response.write session("counter")
%>

request this page multiple times over HTTP. 
View source for this page

repeat over HTTPS
Actual Results:  
The number displayed will be incremented each time the page is requested. When viewing source of the HTTP served page, the source will show the same number that is displayed in the main window. However when repeated over HTTPS the source will have a number one higher than that displayed in the window. Viewing source a second time will show a number 2 higher etc.

Expected Results:  
the text in view-source should be the source code used to render the page

Installed Plugins
=================
Mozilla Default Plug-in
Windows Genuine Advantage validation plug-in
QuickTime Plug-in 7.0.3
VLC multimedia plugin
Shockwave Flash
Google VLC multimedia plugin 1.0
RealJukebox NS Plugin
RealPlayer(tm) G2 LiveConnect-Enabled Plug-In (32-bit)
RealPlayer Version Plugin
Shockwave for Director
Microsoft Office 2003
Yahoo Application State Plugin
Java(TM) 2 Platform Standard Edition 5.0 Update 6
Adobe Acrobat
Windows Media Player Plug-in Dynamic Link Library
Microsoft® DRM

Extensions Installed
====================
IE View 1.2.7
Live HTTP Headers 0.11
Sage 1.3.6
Dom Inspection 1.8.0.3
Talkback 1.5.0.3
Aardvark 1.0 (disabled)
Greasemonkey 0.6.4
SearchStatus 1.15
refspoof 0.7.0
chatZilla 0.9.73
Web Developer 1.0.2
BugMeNot 1.3
OperaView 0.4.1
Flashblock 1.5.1
PDF Download 0.6

Comment 1

12 years ago
There are a slew of bug reports relating to this - Bug 251231 is one of them.

Comment 2

12 years ago
Bugs I've found to date relating to this:
Bug 251231
Bug 306916
Bug 307089
Bug 321291
Bug 340120

I'll bet there are more - this was simply a search in Bugzilla for "view source". 

Updated

11 years ago
Whiteboard: DUPEME
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 307089

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.