POP3 messages fail to download

RESOLVED INCOMPLETE

Status

Thunderbird
General
--
major
RESOLVED INCOMPLETE
12 years ago
10 years ago

People

(Reporter: Mario Vecchi, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2008-08-28)

Attachments

(5 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

Messages from my POP3 server fail to download. It is recurring problem for me, once it starts it's completely reproducible. Several PCs have the same problem, both WIN2K and WinXP, from home network as well as from work, though I'm reporting from this one. I have tried INNUMERABLE configurations of settings, been struggling to see any pattern for months now, unsuccessfully. Problem has been the same through 2 TB upgrades, same behavior. I have seen messages successfully downloaded, though very few times, and certainly not with any consistency. BTW, always works perfectly using Outlook, or my provider web mail interface. 

When reading messages (eg, mpv@vecchi.com) hosted by Web.com/Interland, if the password is stored I briefly get message of email on server (eg, 1 of 10 messages), then blinks off, no other message, no error, and no messages downloaded. If password is not stored, I get the dialog, enter the password, then same behavior. 



Reproducible: Always

Steps to Reproduce:
1.Click on read mail for the POP3 account
2.Watch brief display of new email available to download (eg, 1 of 10 messages)
3.Message blinks off, no error, and no email downloads.

Actual Results:  
No email in dowloaded, no error message is received. 

Expected Results:  
Download new POP3 email.

Current TB version 1.5.0.4, though same problems has been happening for months with 2 previous versions, at least.

Comment 1

12 years ago
I show this identical behavior from win2k, provider Earthlink.

Comment 2

12 years ago
A pop protocol log could be useful (http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#pop)
(Reporter)

Comment 3

12 years ago
Created attachment 224511 [details]
pop3 protocol log

ran pop3 protocol log twice (next log file follows), while reading mail from mpv@vecchi.com. TB indicated 10 new emails available, downloaded none.
(Reporter)

Comment 4

12 years ago
Created attachment 224512 [details]
pop3 protocol log (second)

Comment 5

12 years ago
I have the same problem for a few days (1.5.0.5, also after downgrade to 1.5.0.4 - Windows XP Professional all service packs). I tried to create a new profile and there the messages download. I would escalate this to BLOCKER as it renders Thunderbird unusable.

Comment 6

12 years ago
PARTIAL WORKAROUND

(Hope I remember all steps correctly. Warning! Does not work with 1.5.0.5 and 1.5.0.4 as there you can not change the location of the Local directory! Used 1.5.0.2.)

1. Delete the POP3 account.
2. Close and open Tunderbird.
3. Create the same POP3 account.
4. Close and open Thunderibrd.
5. Change local directory of this account to the old local directory.
6. Close and open Thunderbird.
7. Download now works for 80 messages or so and stops again (have 1300+ on the server).

Very disappointing.
(Reporter)

Comment 7

12 years ago
The bug still remains unresolved, as first reported. Other users also report same behavior. Workarounds are not effective. The only solution I've found is to delete from the POP3 server the existing messages, TB then starts to retrieve new messages after that, till some random event again bloocks the downloads and we're back to square one. This is a TB bug, severe. 

Comment 8

12 years ago
Do you have this problem with a 2.0a nightly? http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-mozilla1.8/

Would be good if we could take a look at the offending mail(s).

Comment 9

12 years ago
Just tested -

thunderbird-2.0a1.en-US.win32.installer.exe 10-Aug-2006 05:47 6.2M

Deinstalled the existing. Restarted. Removed the Thunderbird folder in Program files. Installed the nightly on top of the old profile. Same problem. Reports how many messages are on the server and dies.

Comment 10

12 years ago
do you have a virus checker or other software installed that might be intercepting the pop3 stream and making it look to TB like the server isn't returning any data?

Comment 11

12 years ago
Yes. Norton Internet Security.

Comment 12

12 years ago
VOALA!

Turned OFF Norton and all works fine! What shall we do next?

Comment 13

12 years ago
It's a bug in Norton - complaining to them is the only thing I can think of. If enough users complain, maybe they'll fix it.

I had a similar problem with McAfee - it even had a keep-alive fake protocol from the pretend pop3 server so we didn't time out...

Comment 14

12 years ago
It seems you are right! To test the thing I set test Outlook Express account and it died after less than 100 messages. Now I tried it again with Norton OFF and it flyes.

Sorry for taking so much Mozilla time on this, but did not think of trying without Norton before.

Thanks!
Iavor
(Reporter)

Comment 15

12 years ago
Could be Norton and McAfee bugs ... I have had anti-virus running when the problem surfaced. Good catch.
One point though, is that when I've seen the TB probelm, with Outlook it downloaded messages fine. 
And sorry to say I don't have an instance of the problem at hand, so I could test directly. 
(Reporter)

Comment 16

12 years ago
Created attachment 234723 [details]
FAIL case - FW, AV, SW on
(Reporter)

Comment 17

12 years ago
Created attachment 234724 [details]
FAIL case - FW, AV, SW off
(Reporter)

Comment 18

12 years ago
Created attachment 234725 [details]
SUCCESS - after deleting unread messages
(Reporter)

Comment 19

12 years ago
NEW UPDATE

Still have the same bug, although I was able to test a fail case with and without Firewall, Antivirus and Spyware. 

Also, found that the bug was avoided IF I DELETE ALL UNREAD MESSAGES IN MY SMTP HOST. I was then able to download unread messages, 

I'm attaching POP3 traces for 3 cases: 
- FAIL to download, with FW, AV and SW on
- FAIL to download, with FW, AV and SW off
- SUCCESS downloading new messages, AFTER I DELETED UNREAD MESSAGES ON SMTP server.

Comment 20

12 years ago
re: "An error occurred with the pop3 mail server mail.XXXX.net.au responded:" (Where XXXX is my ISP)
     
RESPONDED?? no response. RESULT? No mail downloaded from my ISP.

This problem started for me last year, using my old pc with win98OS and free AVG virus software. Then I could just close TB, restart it and I could then receive mail.

I am now using a new pc with XP, SP2 and AVG. Before installing AVG I had no problem. The second day after I took delivery of the pc I got all security conscious and had everything blocked/ask me etc. Then the TB error message began.

Initially I went into AVG test centre and unticked TB. Still didn't work even after reboot. Then I disabled Windows firewall and WONDERFUL - TB downloaded my messages. That was all yesterday. Today it is not working again.

All my mail and smtp configuration is as it should be.

I am now going to trawl through the AVG site, but would be grateful for any further ideas. There has to be a quick fix for this! I do not want to do any deep changes on this (until now) pristine machine. If I cant fix it soon I am going to regretfully toss TB and go back to the old and boring I Express.

Comment 21

12 years ago
Since disabling the firewall worked once, are you sure it's still disabled? And no other antivirus/firewall is running?
  

Comment 22

12 years ago
Well, guess what, Magnus? My friend came around (she had trouble SENDING mail with TB after I talked her into having it). She said she changed her server setting in the Options; outgoing box, changing from smtp.XXXX.net.au to mail.XXXX.net.au.

So I thought I would have a fiddle. Changed my incoming server from mail.XXXX.net.au to mail.XXXX.com.au. Now we both are fine. She can send and I can receive. GO FIGURE??

My firewall is running in AVG as I speak and the mail is flowin in! Thanks anyway. But I am darned if I know what the problem was.
cheers
Cal
Reporter, does the issue still occur in the latest supported 2.0.0.x / Shredder trunk nightlies?

(1.5.0.x is now end-of-life and the latest supported 2.0.0.x is 2.0.0.16)
Whiteboard: closeme 2008-08-28
RESO INCO per lack of response to the last question. If you feel this change was made in error, please respond to this bug with your reasons why.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.