Last Comment Bug 340672 - New ATK: Expose Value Change events
: New ATK: Expose Value Change events
Status: RESOLVED FIXED
: access
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: Trunk
: x86 Linux
: -- normal (vote)
: ---
Assigned To: Aaron Leventhal
:
Mentors:
Depends on:
Blocks: newatk
  Show dependency treegraph
 
Reported: 2006-06-07 06:58 PDT by Aaron Leventhal
Modified: 2006-06-26 05:56 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Simple patch (4.64 KB, patch)
2006-06-22 12:10 PDT, Aaron Leventhal
no flags Details | Diff | Splinter Review
Having trouble testing this because of AT poke freezes, but looks right (40.65 KB, patch)
2006-06-22 12:47 PDT, Aaron Leventhal
no flags Details | Diff | Splinter Review
Having trouble testing this because of AT poke freezes, but looks right (3.53 KB, patch)
2006-06-22 13:06 PDT, Aaron Leventhal
evan.yan: review+
Details | Diff | Splinter Review

Description Aaron Leventhal 2006-06-07 06:58:12 PDT
We currently don't expose value change events, although they are very important for support of progress meters and sliders:

We don't expose these events because it was too difficult to find the old value. Let's find a way to expose the event without providing the old value. The spec does not say that detail1 has to be the old value.

See the code:
http://lxr.mozilla.org/seamonkey/source/accessible/src/base/nsRootAccessible.cpp#83

837 #if 0
838   // XXX todo: value change events for ATK are done with 
839   // AtkPropertyChange, PROP_VALUE. Need the old and new value.
840   // Not sure how we'll get the old value.
841   // Aaron: I think this is a problem with the ATK API -- its much harder to
842   // grab the old value for all the application developers than it is for
843   // AT's to cache old values when they need to (when would that be!?)
844   else if (eventType.LowerCaseEqualsLiteral("valuechange")) { 
845     privAcc->FireToolkitEvent(nsIAccessibleEvent::EVENT_VALUE_CHANGE, 
846                               accessible, nsnull);
847   }
848 #endif
Comment 1 Aaron Leventhal 2006-06-22 12:10:37 PDT
Created attachment 226688 [details] [diff] [review]
Simple patch
Comment 2 Aaron Leventhal 2006-06-22 12:47:08 PDT
Created attachment 226689 [details] [diff] [review]
Having trouble testing this because of AT poke freezes, but looks right

Would like to test with http://www.mozilla.org/access/dhtml/slider
Comment 3 Aaron Leventhal 2006-06-22 13:06:55 PDT
Created attachment 226690 [details] [diff] [review]
Having trouble testing this because of AT poke freezes, but looks right
Comment 4 Evan Yan 2006-06-25 23:09:24 PDT
Comment on attachment 226690 [details] [diff] [review]
Having trouble testing this because of AT poke freezes, but looks right

r=me

Note You need to log in before you can comment on or make changes to this bug.