Closed Bug 333492 (newatk) Opened 14 years ago Closed 13 years ago

Implement new-atk

Categories

(Core :: Disability Access APIs, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla1.9alpha1

People

(Reporter: aaronlev, Assigned: aaronlev)

References

Details

(Keywords: access, meta)

We need to implement the reorganization of document structure and text as explained here:
http://www.mozilla.org/access/unix/new-atk.html

We will use the last column in the table as agreed by the FSG - "ATK
using Hypertext and Hyperlink children"

We will move more of the code into cross-platform areas (mozilla/accessible/src/base) to make implementation of ATK-like interfaces easier on other platforms.
No longer depends on: fox2access
Target Milestone: --- → mozilla1.9alpha
No longer blocks: fox2access
Depends on: fox2access
Alias: newatk
The following document may also provide useful info:
http://accessibility.freestandards.org/a11yspecs/atspi/adoc/ADOC_ATSPI.htm
Blocks: 324745
Depends on: 334650
Depends on: 339310
Depends on: 339311
Depends on: 339314
Depends on: 340661
Blocks: 334650, 339310, 340661
No longer depends on: 334650, 339310, 339311, 339314, 340661
Depends on: 340665
Depends on: 340667
Depends on: 340668
Depends on: 340670
Depends on: 340671
Depends on: 340672
No longer blocks: 339310
Depends on: 340777
Depends on: 340802
Depends on: textattra11y
Depends on: 340822
Depends on: 340825
Depends on: 340827
Depends on: 340829
Depends on: 340830
No longer blocks: 340661
Depends on: 340661
Depends on: 340833
That second document is incomplete and not entirely up to date.
Depends on: 341013
Depends on: 341386
Depends on: 341747
Depends on: 342045
Depends on: 342288
Depends on: 342308
Depends on: 312093
No longer depends on: 340777
No longer depends on: 340670
No longer depends on: 342288
No longer depends on: 342308
No longer depends on: 340830
Depends on: 342596
Depends on: 322903
No longer depends on: 342596
Depends on: 285167
Blocks: keya11y
No longer depends on: fox2access
No longer depends on: 285167
Depends on: 255073
*** Bug 337530 has been marked as a duplicate of this bug. ***
Depends on: 337533
Depends on: 313443
Depends on: 278034
Depends on: 275010
Depends on: 343136
Depends on: 343150
Depends on: 343156
*** Bug 309282 has been marked as a duplicate of this bug. ***
Depends on: 334353
Depends on: 260921
Depends on: 214580
*** Bug 187212 has been marked as a duplicate of this bug. ***
Depends on: 320357
Depends on: 322453
No longer depends on: 214580
Depends on: 344392
Depends on: 344901
Depends on: 345143
No longer depends on: 345143
Depends on: 345192
Depends on: 345275
Depends on: 345421
Depends on: 345422
Depends on: 345424
Depends on: 345434
Depends on: 345723
Keywords: meta
Depends on: 345825
Depends on: 346621
Depends on: 346833
Depends on: 346846
Depends on: 346906
No longer depends on: 346833
No longer depends on: 345723
Depends on: 347171
No longer depends on: 322453
Depends on: 348037
Depends on: 348616
Depends on: 348901
Depends on: 349519
Depends on: 349533
Depends on: 349635
Depends on: 349909
No longer depends on: 278034
No longer depends on: 342045
Depends on: 350063
Depends on: 350565
Depends on: 352150
Depends on: 352194
Depends on: 352195
Depends on: 352214
Depends on: 352340
Depends on: 352205
Depends on: 352522
Depends on: 352533
No longer depends on: 352205
No longer depends on: 352533
Depends on: 353187
Blocks: 353197
Depends on: 353293
No longer blocks: 353197
Depends on: 353197
Depends on: 353200
Depends on: 350381
Depends on: 343904
Depends on: 352520
Depends on: 354832
Depends on: 357056
Depends on: 357032
Depends on: 357430
Depends on: 357432
Depends on: 357837
Depends on: 357625
Depends on: 356152
Depends on: 358085
Depends on: 358979
Depends on: 359204
Depends on: 359210
No longer depends on: 359204
Depends on: 359790
Depends on: 359792
Depends on: 360003
Depends on: 360184
Depends on: 356347
Depends on: 356045
Depends on: 357230
Depends on: 359924
Depends on: 358782
Depends on: 360865
Depends on: 355380
Depends on: 362445
Depends on: 363200
Depends on: 363198
Depends on: 363214
Depends on: 363646
No longer depends on: 358782
Depends on: 365685
Depends on: 366443
No longer depends on: 359792
Depends on: 366527
Depends on: 366000
Depends on: 365683
Depends on: 367337
Depends on: statesa11y
Depends on: 367653
No longer depends on: 357430
No longer depends on: textattra11y
No longer depends on: 348901
No longer depends on: 360003
No longer depends on: 360184
No longer depends on: 357432
No longer depends on: 343904
No longer depends on: 366527
Big bug reorg. Closing this as basically being basically feature complete, and moving remaining bugs to other meta bugs.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
No longer depends on: 366000
No longer depends on: 363214
You need to log in before you can comment on or make changes to this bug.