list window does not update when card deleted

RESOLVED FIXED

Status

Thunderbird
Address Book
RESOLVED FIXED
12 years ago
10 years ago

People

(Reporter: LeeF, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.3) Gecko/20060427 Camino/1.0.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.3) Gecko/20060427 Camino/1.0.1

address book sub-list should update as soon as you choose Delete for a chosen card. It appears that the card is not deleted, but it is and the list will redo itself if you display a different list and then go back to the one you were working with.

Reproducible: Always

Steps to Reproduce:
1. choose a List under Personal Address Book
2. highlight a card in that List
3. hit Delete.

Actual Results:  
list of cards in that List does not change so you think the Delete didn't work.

Expected Results:  
list should update right away.

using TBird 1.5.0.4, only extension is addressContext 0.7

Comment 1

12 years ago
The user is faced with severe cognitive dissonance (e.g., spades are coloured red and hearts are black) when he thinks something did not work when it actually does work eventually. Even if he opens and closes the address book to look at the same item to confirm if it has been deleted, the deleted item still appears to be there. It ONLY disappears if you open and close another list. This is very poor usability design since the user may spend a lot of wasted effort trying to delete a item from the list and confirm it.
I'm using TBird 1.5.0.9 on Windows XP Pro

Comment 2

11 years ago
Problem remains, TB 1.5.0.12 on Win XP.

Comment 3

11 years ago
Problem remains: version 2.0.0.9 (20071031) on win xp
This has been fixed by bug 406921 for the next major releases of Thunderbird (3.0) and SeaMonkey (2.0)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Depends on: 406921
You need to log in before you can comment on or make changes to this bug.