Closed Bug 34073 Opened 20 years ago Closed 17 years ago

Need Pop3 Compact Folder status update while compacting

Categories

(SeaMonkey :: MailNews: Message Display, defect, P3)

x86
Windows NT
defect

Tracking

(Not tracked)

VERIFIED FIXED
mozilla1.0.1

People

(Reporter: jefft, Assigned: Bienvenu)

References

Details

We need to have percentage update while compacting the folder.
QA Contact: lchiang → laurel
reassigning to Jeff for now.
Assignee: selmer → jefft
Status: NEW → ASSIGNED
Target Milestone: --- → M16
Not beta2 stopper, marking M18.  Please add beta2 keyword if you disagree.
Target Milestone: M16 → M18
reassigning jefft's bugs to naving
Assignee: jefft → naving
Status: ASSIGNED → NEW
Target Milestone: M18 → ---
I'll look at this.
Assignee: naving → bienvenu
nominating - I'll need this for showing status when cleaning up offline storage use.
Status: NEW → ASSIGNED
Keywords: nsbeta1
Target Milestone: --- → mozilla0.9.1
marking nsbeta1+
Whiteboard: [nsbeta1+]
QA Contact: laurel → sheelar
Wasnt this checked in today? 13:14?
yes, it was checked in but the bug is not completely fixed - the percentage
progress is updated, but the status message that says which folder is getting
compacted is getting overwritten by some other status message. I'm going to try
to rewrite folder compaction anyway, which might fix the overwriting, so I'm
leaving this open.
seems to be working - status msg seems to be displayed correctly now.
Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
buildid: 2001051506
I deleted few messages from the each local folder and did compact folders from 
the menu item.  It does update in the status for few folders but does not show 
the status update of each folder.  The status bar then gets stuck at 'compacting 
 folder '....' it could be any folder that it can state. Untill I move the mouse 
the status remains at that particular folder and then changes to 'Document Done' 
in the status bar. I still see the status update does not show all the folder 
that it is compacting. 
I am reopening this bug because it did not work for me. Also the the way bug is 
logged is to show the percentage done while compacting local folders but we 
update status with which folder we compact. Since we don't go by each folder in 
the status it appears that only 1 or 2 folders were compacted. 
If what I am verifying was not correct please state and I will verify it 
accordingly
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
moving to 0.9.2
Target Milestone: mozilla0.9.1 → mozilla0.9.2
We only show the percent done on each folder; that's on purpose - it's hard to
do the total percent done. Some folders compact so quickly that you won't see
status (or it will get overwritten quickly). I don't know about the getting
stuck part.
moving to 0.9.3
Target Milestone: mozilla0.9.2 → mozilla0.9.3
Target Milestone: mozilla0.9.3 → mozilla0.9.4
moving to 0.9.5
Target Milestone: mozilla0.9.4 → mozilla0.9.5
moving - this is hard to fix, and probably not worth the effort in the short 
term.
Target Milestone: mozilla0.9.5 → mozilla0.9.7
Blocks: 104166
Whiteboard: [nsbeta1+]
Target Milestone: mozilla0.9.7 → mozilla1.0.1
Keywords: nsbeta1-
I am changing this bug as fixed for the fact that we show the status per folder 
compaction. 
Since this bug was not specifically logged to track the total progress. 
Branch builds: 2002-07-15-08 win98,linux,mac os x.
We currently have been showing progress per folder during compaction.  I will 
log a seperate to be able to track the total progress as enhancement. 
Status: REOPENED → RESOLVED
Closed: 19 years ago17 years ago
Resolution: --- → FIXED
Verifying as fixed cause now we do show progress per folder during compaction. 
Status: RESOLVED → VERIFIED
*** Bug 149683 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.