Location bar dropdown that is opened by text inputting does not disappear on click the dropdown button

RESOLVED DUPLICATE of bug 1148716

Status

()

defect
--
minor
RESOLVED DUPLICATE of bug 1148716
13 years ago
3 years ago

People

(Reporter: masayuki, Unassigned)

Tracking

({regression})

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

1. Type text on location bar until popup the dropdown list.
2. Click the dropdown button.

the dropdown list is closed, but it's reopened immediately.

This is regression of bug 340131. But I have no idea for fixing this.
> This is regression of bug 340131. But I have no idea for fixing this.

I am able to reproduce this on windows, and this will be fixed by my fix for bug #404438

I think it is a duplicate, except that the steps to reproduce are different, so we might want to keep this as a separate bug so that we can verify it separately and get it into litmus separately.
Assignee: nobody → sspitzer
Depends on: 404438
Target Milestone: --- → Firefox 3 M11
(In reply to comment #1)
> > This is regression of bug 340131. But I have no idea for fixing this.
> 
> I am able to reproduce this on windows, and this will be fixed by my fix for
> bug #404438

As far as I can tell this wasn't fixed by that bug. We don't consume the rollup event for "normal" autocomplete popups (triggered by typing), so the dropmarker gets the click event that dismisses the initial popup, and opens the history popup.

I'm not sure that this is really a bug, though - IE on Windows behaves the same way.
Assignee: moco → nobody
No longer depends on: 404438
Whiteboard: WONTFIX?
OS: Windows 2000 → All
Hardware: PC → All
Target Milestone: Firefox 3 beta3 → ---
Original STR do not exhibit the bug in 1.9.1. Clicking on the arrow closes the popup, and it does not immediately re-open.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WORKSFORME
Whiteboard: WONTFIX?
reproduce with Firefox/20090704-trunk/WinXP

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090704 Minefield/3.6a1pre
I can also reproduce with recent trunk Linux build.
This may not be a bug but I am reopening anyway.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090707 Minefield/3.6a1pre
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
I think this is a duplicate of bug 1148716. That bug indicates it is fixed now.
Masayuki, are you still able to reproduce it with Nightly? Can we close this old bug?
Flags: needinfo?(masayuki)
Yeah, it's not reproducible now.
Status: REOPENED → RESOLVED
Closed: 11 years ago3 years ago
Flags: needinfo?(masayuki)
Resolution: --- → DUPLICATE
Duplicate of bug: 1148716
You need to log in before you can comment on or make changes to this bug.