Close Tab button should be available in multiple places

RESOLVED DUPLICATE of bug 324227

Status

()

Firefox
Toolbars and Customization
--
minor
RESOLVED DUPLICATE of bug 324227
12 years ago
12 years ago

People

(Reporter: Aleksey V. Lazar, Unassigned)

Tracking

2.0 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1a3) Gecko/20060526 BonEcho/2.0a3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1a3) Gecko/20060526 BonEcho/2.0a3

The Close Tab button used to be available in the far right side of the tab menu, and now it's on the tabs themselves. This is sometimes useful, but most of the time is not. I used to be able to click-click-click to close several unneeded tabs fast, now I have to aim for the separate close buttons every time. This especially comes up when viewing multiple listings on ebay, reading multiple slashdot stories, looking through multiple results on google -- you name it. I know there is a Close Other Tab feature, but most of the time I need to leave more than one tab open. Speed clicking a button that's in one place seemed to be the fastest way for me.

Reproducible: Always

Steps to Reproduce:
1.Open 20 tabs.
2.Close 18 of them very quickly. (You can't without keyboard shortcuts, etc.)
3.Compare to closing them by clicking one button in the same place (much quicker)

Actual Results:  
Slow tab closing.

Expected Results:  
Fast tab closing.

I think that the Close Tab button should be available on the tabs, but also   where it was previously -- in the far right location of the tab bar. Or, it could be made available as an optional item from the Customize Toolbar menu, and then it could be placed wherever the user wants it. I really don't mean to whine (too much), but I always preferred the old style firefox tab closing to what it was in other browsers -- operas, etc. So now that it's changed it feels like a step back. So it would be nice to have a UI function I liked not go away.
I was just thinking about this earlier. It's probably a DUPE, though. :/
OS: Linux → All
Hardware: PC → All
Whiteboard: DUPEME?
Version: unspecified → 2.0 Branch
You can use the "Tab No X" extension to revert to the previous behavior.
https://addons.mozilla.org/firefox/1919/

*** This bug has been marked as a duplicate of 324227 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME?

Comment 3

12 years ago
*** Bug 358304 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.