Incorrect user response should offer a fuzzed list of possible matches

RESOLVED DUPLICATE of bug 341090

Status

()

Bugzilla
Creating/Changing Bugs
--
enhancement
RESOLVED DUPLICATE of bug 341090
12 years ago
12 years ago

People

(Reporter: timeless, Unassigned)

Tracking

Details

(Reporter)

Description

12 years ago
I just spent the last 7 or so submits trying to cc marcia, and assign to justdave.

first i botched justdave who is not @mozilla.org, but mozilla.com
then it turns out i typed macria@moz, i tried fixing it to macrcia@moz, but that didn't work, i kept trying to change the username but it took me a number of attempts to before i noticed that i had transposed the c.

expected results:
selecting justdave@mozilla.org should yield:

could not find justdave@mozilla.org, did you mean justdave@mozilla.com?

logic used: corrections should be as few changes as possible to yield a result. changing the tld should be considered more optimal than changing the host even though org=>com is 3 letters and mo=>bug is 2.5 letters.

macria@moz to => marcia@moz is a single transposition (and all other transpositions of macria fail to yield any results).

incomplete bits (@moz isn't a valid host according to our rules) should be assumed to be correctly typed.

order of operations:
1. work from right to left
2. try transpositions
3. try wild matches

results should only be given if they yield a very small answer (not more than 3).

Comment 1

12 years ago

*** This bug has been marked as a duplicate of 341090 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.