[Mac]when dragging and dropping a bookmark into the bookmarks menu, we don't scroll when over the arrowscrollbox

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
RESOLVED WORKSFORME
12 years ago
5 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Unassigned)

Tracking

Trunk
All
Mac OS X
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

when dragging and dropping a bookmark into the bookmarks menu, we don't scroll when over the up / down arrows.

to reproduce:

1)  have a bookmarks folder with lots of bookmarks, enough so when you open the folder in the menu, you get the scroll bars

2)  select a link, and drag over the bookmarks menu, and attempt to file in the folder with lots of bookmarks.

expected results: when you drag over the up / down arrows, it should scroll.
actual results:   you get the "can't drop" drop icon

note, this is something we're adding for the horizonal scrollbox for #318168
No longer depends on: 318168
Depends on: 318168
See also bug 240709 (of which this is a duplicate) and bug 194319 (of which that is a duplicate).
> See also bug 240709 (of which this is a duplicate) and bug 194319 (of which
> that is a duplicate).

thanks phil!  bug #194319 is especially interesting, see bug 318168 comment 43 for how the patch in that bug may help me.
for mac, onDragOver is not being called repeatedly when the mouse isn't moving, as it does on windows.

From an ancient post from pink (http://groups.google.com/group/netscape.public.mozilla.mac/browse_thread/thread/6cd00f8ae7b6e07a/192a62a1599f0bc1)

Here's how Mac D&D is working so far: 

- each window (mac window) registers a tracking handler and a receive
handler with the drag manager
- the tracking handler gets called when the mouse enters/leaves the
window and when the mouse moves within the window.
- the receive handler gets called when a drop over a window occurs.

mark suggested that I might need a timer to solve this problem, but I wanted to ping pink and see if I'm on the right track.
Depends on: 342357
in addition to bug #342357 (where this doesn't work on the trunk), I think there may be issues if we try to do this.

for bug #318168, there is code for a horizontal scroll box to scroll on drag over, but for menus, there might be some problems on the mac.

at least, I sort of remember discussing this with pinkerton (or ben?)
Depends on: 364018
No longer depends on: 342357

Comment 5

10 years ago
WFM on Windows, i can't tell if this was fixed on Mac too due to the above comments. Changing platform to Mac.
OS: Windows XP → Mac OS X
Hardware: x86 → All
Same bug affects Thunderbird- so its definitely a Mozilla Core problem.

In my extension QuickFolders...
https://addons.mozilla.org/en-US/thunderbird/addon/3254
...you can drag emails onto popup menus that represent the folder tree, if the list exceeds the screen the drag chevron does not scroll down the menu list. Should I file a separate bug report for this?

See also https://www.mozdev.org/bugs/show_bug.cgi?id=21054
The bug can be reproduced in Thunderbird under Windows XP using the QuickFolders extension, I had quite a few bug reports from QuickFolders users about this.

Steps to reproduce:
1. Install Thunderbird 3.0.1 (or 3.0.2b)
2. Install https://addons.mozilla.org/en-US/thunderbird/addon/3254
3. Drag a folder with many subfolders into the quickfolder toolbar - this creates a new QF tab
4. highlight an email from the message pane and drag it to the QF tab, hovering over it...
5. ... this will drop down the menu - pull down the email to the arrow at the bottom
=> the menu does not scroll (TB3.0.2b, Windows XP SP3)

Any news or intentions to fix this for TB 3.0.3?

I will attach a screenshot...
Axel
Created attachment 428752 [details]
dragging in TB3 - no scrolling

For a complete test case, please see my previous comment

Axel

Comment 9

8 years ago
Fixing this bug would greatly improve the usefulness of the QuickFolders Add-on for Thunderbird.
I have integrated Richard's code from:
https://bugzilla.mozilla.org/show_bug.cgi?id=194319#c21

extension:
https://addons.mozilla.org/extensions/moreinfo.php?id=1411

...into QuickFolders, which now makes the bookmarks scroll as expected (TB3.0.3 / WinXP). It will be released with the next version (QF 1.8.9 or 1.9). 

In the meantime, a test version for QuickFolders users can be downloaded here:
https://www.mozdev.org/bugs/show_bug.cgi?id=21054#c26

please leave some comments there if it works for you.

Updated

8 years ago
Summary: when dragging and dropping a bookmark into the bookmarks menu, we don't scroll when over the arrowscrollbox → [Mac]when dragging and dropping a bookmark into the bookmarks menu, we don't scroll when over the arrowscrollbox
Marco, can you test whether the fix works on Mac? If your not a QuickFolders user, just ignore my request. I will probably run some tests on SeaMonkey & Postbox later and update my bug.

thx,
  Axel

Comment 12

8 years ago
Tested on TB 3.0.1 running on XPsrv3. 
Works OK. There's some stuttering in the scroll, but it works.
Thanks for this guys. It makes a huge improvement in utility.
Unable to reproduce using a recent build of Firefox (19.0.2) on Lion.

Please re-open if this is still an issue.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.