Closed Bug 341895 Opened 18 years ago Closed 10 years ago

Reload button should be disabled until URL is added to session history (starts loading)

Categories

(Camino Graveyard :: Toolbars & Menus, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: froodian, Unassigned)

References

Details

Here's a fun way to lose data:

1. Find a slow connection
2. Open a URL
3. While the browser is in the "Looking up http://foo.bar" stage, Cmd-R

What happens: about:blank is displayed, and the URL is gone.

Apparently, in core, they decided that the URL should not be added to the session history before it begins to load (see bug 95897).

If we go with that, the Reload button should be disabled until loading URLs are added to the session history so the user won't accidentally lose the URL by clicking the Reload button.

Otherwise, we should remember the URL and actually reload the page.

The corresponding Core bug is bug 125772, but if I understand how this stuff works correctly, we won't get the fixes from that.  If I'm wrong, feel free to dupe.
Blocks: 341853
I don't think we can change how session history behaves, and the Core bug implies that its fix should be done in app-level code, so confirming.

Just make sure the button is re-enabled if one hits stop/cmd-period so one can reload the prior page.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Reload button should be disabled until URL starts loading → Reload button should be disabled until URL is added to session history (starts loading)
I made a quick test and Firefox 2.0.0.1 seems to work the way you proposed: When I typed a web address in Firefox and tried to press F5 to reload the page before rendering had started, nothing happened. The reload button was also disabled, so the only way to interfere with page loading was the Stop button (or Esc) or closing the tab.

The addresses I tested were found in my browser history and typed addresses list even though I pressed stop before the pages had anything to render. None of the addresses were previously visited, some weren't even proper web addresses.
Forgot to mention, that was a Windows version of Firefox I tested. I also have Ubuntu Linux available with Firefox 2.0.0.1 installed in case testing with it would be of any help.
This bug is specific to Camino.
This bug has been buried in the graveyard and has not been updated in over 5 years. It is probably safe to assume that it will never be fixed, so resolving as WONTFIX.

[Mass-change filter: graveyard-wontfix-2014-09-24]
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.