Cut off ui in Appearances prefs pane

RESOLVED FIXED in seamonkey1.1alpha

Status

SeaMonkey
Preferences
RESOLVED FIXED
12 years ago
10 years ago

People

(Reporter: stefanh, Assigned: stefanh)

Tracking

({fixed-seamonkey1.1a})

Trunk
seamonkey1.1alpha
PowerPC
Mac OS X
fixed-seamonkey1.1a

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 2 obsolete attachments)

(Assignee)

Description

12 years ago
The "Resize large images..." line is cut off at the bottom. It's barely readable. I see this on trunk and 1.8 branch. This is probably old, can be seen on a trunk build from January 23.

Comment 1

12 years ago
trunk and 1.8 brnach have the chatzilla start pref exposed in the pref panel (1.8.0 branch does not), so if it was just barely fitting before, there would be too much content now.

Comment 2

12 years ago
noting that this may be fixed with my (yet to file) prefwindow bug.
(Assignee)

Comment 3

12 years ago
(In reply to comment #1)
> trunk and 1.8 brnach have the chatzilla start pref exposed in the pref panel
> (1.8.0 branch does not), so if it was just barely fitting before, there would
> be too much content now.
> 

Yeah, bug 123258 caused this.
(Assignee)

Comment 4

12 years ago
Well, I suppose we could lay out the radiogroup horizontally... Hmm, or move the browser-specific stuff to a better place?

Comment 5

12 years ago
You can CC me all you want, but I don't have a mac so I can neither reproduce nor help here. If the dialog doesn't resize sensibly then that's a problem with the dialog itself, not with the addition of more checkboxes. I might add that I don't have any problems on Windows (with current latest-trunk as found on ftp.mozilla.org). Which would then imply the problem is the mac theming or dialog, which means either of those should be fixed, instead of changing the layout cross-platform.
(Assignee)

Comment 6

12 years ago
Created attachment 226166 [details]
Screenshot of prefs panel with radiogroup laid out horizontally
(Assignee)

Comment 7

12 years ago
(In reply to comment #5)
> You can CC me all you want, but I don't have a mac so I can neither reproduce
> nor help here. If the dialog doesn't resize sensibly then that's a problem with
> the dialog itself, not with the addition of more checkboxes. I might add that I
> don't have any problems on Windows (with current latest-trunk as found on
> ftp.mozilla.org). Which would then imply the problem is the mac theming or
> dialog, which means either of those should be fixed, instead of changing the
> layout cross-platform.
>

Well, then I can inform you that the dialog is *not* resizable on mac (and has never been).
(Assignee)

Comment 8

12 years ago
Created attachment 226171 [details] [diff] [review]
patch

Comment 9

12 years ago
(In reply to comment #7)
> Well, then I can inform you that the dialog is *not* resizable on mac (and has
> never been).

It's not resizable on Windows either (and I think the same goes for Linux). The point of what I said was that the dialog should be big enough (resize) to encompass its child boxes. sizeToContent is what you'd use for that if it doesn't happen normally in any other dialog. However, SeaMonkey's pref window is so complicated and weird that I'm not sure whether that's a solution. As said, I can't really do anything constructive for this bug (unless you're asking me to back out which doesn't seem to be the case). 

Reference for sizeToContent: http://developer.mozilla.org/en/docs/XUL_Tutorial:Creating_Dialogs

As for your patch, I would object to your modification (though I should note I have no say whatsoever in the matter, so one is free to ignore this part of my comment as advocacy). Specifically because while this fits on Mac, in US English, it might cause problems when you use some other language (and the options won't fit). And additionally, because I consider it silly to change a dialog on all platforms for a platform that is obviously specific to one platform, and should hence be fixed on that platform. You're working around, not fixing the problem.

Justin: could you file that bug or elaborate on what you're proposing to do?

Comment 10

12 years ago
(In reply to comment #9)
> And additionally, because I consider it silly to change a
> dialog on all platforms for a platform that is obviously specific to one
> platform, and should hence be fixed on that platform.
Er, obviously I meant "for a problem that is obviously specific to one platform". Sorry for bugspam.

(Assignee)

Comment 11

12 years ago
Yeah, I tend to agree. Well - I guess another option would be to just make the window higher on mac. I don't see any other way atm to work around the problem.
(Assignee)

Comment 12

12 years ago
(In reply to comment #11)
> Yeah, I tend to agree. Well - I guess another option would be to just make the
> window higher on mac. I don't see any other way atm to work around the problem.
> 
I don't see any other way atm *than* to work around the problem.

Comment 13

12 years ago
I suppose the other option is to have the checkboxes in the top group box in a grid of two columns.
re: c#2 and c#9

I decided to file it: Bug 342087
(Assignee)

Comment 15

12 years ago
So, if we want to fix this for 1.1a it looks like we have 3 options here:

1) Make the pref window larger on mac
2) A horizontally laid out radiogroup
3) Have the checkboxes in the top group box in a
   grid of two columns

IanN, Mnyromyr - what do you think?

Comment 16

12 years ago
(In reply to comment #15)
Horizontal radiogroup for is fine by me now. 
(Assignee)

Comment 17

12 years ago
Created attachment 226980 [details] [diff] [review]
1.8 branch hack

Branch patch. No need to use 'align="start"' on the groupbox, it seems. I don't know if there's any need to patch trunk. One could probably fix it by changing  font in the pref window and I imagine that it might be better to wait and see how it looks in suiterunner when everything has settled down a bit.
Assignee: prefs → stefanh
Attachment #226171 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #226980 - Flags: superreview?(neil)
Attachment #226980 - Flags: review?(mnyromyr)
(Assignee)

Comment 18

12 years ago
Created attachment 226981 [details] [diff] [review]
Real branch patch

Bah, wrong tree - here's the "real" branch patch.
Attachment #226980 - Attachment is obsolete: true
Attachment #226981 - Flags: superreview?(neil)
Attachment #226981 - Flags: review?(mnyromyr)
Attachment #226980 - Flags: superreview?(neil)
Attachment #226980 - Flags: review?(mnyromyr)

Comment 19

12 years ago
One other approach would be to use a checkbox listbox for the preferences.
Another approach would be to use a menulist for the text/icon choices;
I'm worried that a horizontal radiobox will be bad for l10n; KaiRo?

Updated

12 years ago
Attachment #226981 - Flags: superreview?(neil)
Attachment #226981 - Flags: superreview+
Attachment #226981 - Flags: review?(mnyromyr)
Attachment #226981 - Flags: review+
(Assignee)

Comment 20

12 years ago
Comment on attachment 226981 [details] [diff] [review]
Real branch patch

There are fears that this will have a negative impact on l10n - KaiRo, are you ok with this for 1.1a? See comment #15 and comment #19 for other options.
Attachment #226981 - Flags: approval-seamonkey1.1a?

Comment 21

12 years ago
Comment on attachment 226981 [details] [diff] [review]
Real branch patch

I think this is good to try as a "quick" fix, but we'll have to listen closely if localizers have a problem with it in practice.

Actually, I think doing option 3) of comment #15 as well would probably a good idea anyways, to make sure we have enough space even for future additions.
Attachment #226981 - Flags: approval-seamonkey1.1a? → approval-seamonkey1.1a+
(Assignee)

Updated

12 years ago
Target Milestone: --- → seamonkey1.1alpha
Version: Trunk → 1.8 Branch
(Assignee)

Comment 22

12 years ago
Checked in by ajschult (branch/trunk)
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Keywords: fixed-seamonkey1.1a
Resolution: --- → FIXED
Version: 1.8 Branch → Trunk
(Assignee)

Updated

12 years ago
Blocks: 349436
You need to log in before you can comment on or make changes to this bug.