Inbox Date sort order is reversed in Windows/Linux dual-boot

RESOLVED WORKSFORME

Status

--
minor
RESOLVED WORKSFORME
13 years ago
12 years ago

People

(Reporter: hgdingman, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Thunderbird version 1.5.0.4 (20060516) and previous

Cosmetic bug - dual-boot system, running SuSE 10.0 and Windows 2000 (FAT-32). Thunderbird user data file stored in Windows partition, accessed from both OS's. Inbox sorted by date. View pane order is "descending" in Linux when "ascending" in Windows, and vice-versa. Changing ascending/descending sort in either OS affects both, but view is always sorted opposite when booted into the other OS.


Reproducible: Always

Steps to Reproduce:
1.Install Thunderbird in Windows, create user mailbox. Download some messages; click "Date" tab to sort messages either ascending or descending.
2.Reboot in Linux, mount Windows partition R/W 
3.Install Thunderbird in Linux, set Thunderbird data file location into Windows data file (absolute file location, not relative to ~/.Thunderbird)
4.Start Thunderbird in Linux, open Inbox if not default
Actual Results:  
Messages from Windows Inbox, in Linux Inbox window are all present, but date sort is reversed - if messages were "date ascending" in Windows, they are "date descending" in Linux.

Expected Results:  
Expected ascending/descending sort to be the same on both OSs.

Looks like different interpretation of the same flag. Both OS's correctly read all data put into the file by either system. Reversing sort order in either OS affects the display in both OS's. 

Trivial workaround - click the "date" bar again and the sort order is reversed, just do it each time when switching OS's.
(Reporter)

Comment 1

12 years ago
now OK in 1.5.0.5
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
-> WFM (FIXED is used only when known code changes resolved the issue)
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Updated

12 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.