Changing identity when composing should change mail format (plain text/HTML) to match

RESOLVED DUPLICATE of bug 275804

Status

--
enhancement
RESOLVED DUPLICATE of bug 275804
13 years ago
11 years ago

People

(Reporter: huberokororo, Assigned: mscott)

Tracking

(Depends on: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; cs; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; cs; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

When using two accounts with local folders only and message format is different for each account. When composing a new message the setting is taken from the default account and does not change when account with another setting is selected.

Reproducible: Always

Steps to Reproduce:
1. Have two accounts and use Local folders.
2. Tools > Account Settings... > Composition & Addressing> Compose messages in HTML format is UNCHECKED for account 1.
3. Tools > Account Settings... > Composition & Addressing> Compose messages in HTML format is CHECKED for account 2.
4. Account 1 is default.
5. Compose a new message (default account setting is loaded for message format - plain text)
6. Change account to account 2 (which has HTML message format enabled)
Actual Results:  
Impossible to compose a HTML message, although it is enabled in account 2 settings.

Expected Results:  
When chaneging accounts the Compose message window should switch mode to message format specified in selected account settings.

When using Local folders for all accounts it is not possible to compose a message in other mode then specified in setting for default folder.

Updated

13 years ago
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Component: Message Compose Window → MailNews: Composition
Depends on: 140800
Ever confirmed: true
OS: Windows XP → All
Product: Thunderbird → Core
Hardware: PC → All
Summary: Changing account when composing a message does not apply to mail format (plain text/HTML) → Changing identity when composing should change mail format (plain text/HTML) to match
Version: unspecified → Trunk

Comment 1

13 years ago
*** Bug 346919 has been marked as a duplicate of this bug. ***

Updated

12 years ago
Duplicate of this bug: 366577

Updated

12 years ago
Duplicate of this bug: 370837

Comment 4

11 years ago
Duplicate of (Thunderbird bug 283178 ->) bug 275804.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 275804
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.