Trailing space in imported LDIF email address gives weirdly quoted address when selected

VERIFIED DUPLICATE of bug 286760

Status

Thunderbird
Address Book
--
minor
VERIFIED DUPLICATE of bug 286760
12 years ago
10 years ago

People

(Reporter: andrew, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Thunderbird 1.5.0.4

If there is an LDIF file with address records such as
dn: cn=Mr. Joe User ,mail=joe.user@example.com \n
mail: joe.user@example.com \n
then, when it is imported, and the record used to send email, it
produces an address such as
"Mr. Joe User" <"joe.user"@example.com>

This appears to be accepted as <joe.user@example.com> by Sendmail,
but rejected as unknown by Exchange

Removing the trailing spaces to give e.g.
dn: cn=Mr. Joe User ,mail=joe.user@example.com\n
mail: joe.user@example.com\n
or converting to DOS/network line format e.g.
dn: cn=Mr. Joe User ,mail=joe.user@example.com\r\n
appears to fix this

Reproducible: Always

Steps to Reproduce:
1. Import LDIF file
2. In message comoposer, select this mailing list from drop-down list
3. Select one or more names from list as To: (Cc:, etc.)

Actual Results:  
Malformed address generated

Expected Results:  
Either:
 - generated an error when importing malformed LDIF (I think, from RFC2849/2253,
that a space is not allowed at the end-of-line, though it must be ignored around commas)
- or, ignore the unexpected trailing space and generate a normal address
Actually you don't have to import the card to do this, just add a space on the end of the email address -> duplicate of bug 286760.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 286760
V.Duplicate
Status: RESOLVED → VERIFIED
Version: unspecified → 1.5
You need to log in before you can comment on or make changes to this bug.