Closed Bug 342494 Opened 15 years ago Closed 15 years ago

rdf parsing error: -- in double quotes in a commented part gets interpreted, but shouldn't

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 102127

People

(Reporter: scopsen, Unassigned)

References

()

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

I have a problem with the following in an html/php file which is not parsed correctly.

<!--
<rdf:RDF xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
         xmlns:trackback="http://madskills.com/public/xml/rss/module/trackback/"
         xmlns:dc="http://purl.org/dc/elements/1.1/">
<rdf:Description
         rdf:about="http://blog.passeport-chine.com/index.php?/feeds/ei_4.rdf"
         trackback:ping="http://blog.passeport-chine.com/comment.php?type=trackback&amp;entry_id=4"
         dc:title="Test -- Test"
         dc:identifier="http://blog.passeport-chine.com/index.php?/archives/4-Test-Test.html" />
</rdf:RDF>
-->

The "--" in "dc:title="Test -- Test"" causes FF to think the comment is finished. Result is the final "-->" is outputted on the screen.

Reproducible: Always

Steps to Reproduce:
1. Just put the abovementioned source in a file.
2. Open it in firefox...

Actual Results:  
The "-->" is outputted on the screen.

Expected Results:  
Interprete it right and not output the "-->"
See bug 102127 comment 16 for as good as any of the other explanations in various other duplicate bugs: quotes don't matter, nothing matters except that once you say "<!" then the following "--" starts a comment, any characters other than "--" are in the comment, and the very first instance of "--" ends the comment. It's a bug in WordPress that it doesn't escape them in the Trackback RDF (though, just how you would escape something in a hotcomment is an interesting question, for the bug you'll be filing on WordPress, or maybe the Trackback standardization mailing list).

*** This bug has been marked as a duplicate of 102127 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.