phantom context menu prevents normal main-window behavior

VERIFIED DUPLICATE of bug 34079

Status

SeaMonkey
General
P3
normal
VERIFIED DUPLICATE of bug 34079
18 years ago
14 years ago

People

(Reporter: jon rekai, Assigned: Christine Begle)

Tracking

Trunk
x86
Windows 95

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Right-clicking in main-window's content area to raise a context menu appears to 
raise nothing, but some accesskeys for menuitems are usable.  Looks like popup 
'context' gets its oncreate handler called TWICE initially.  Context menu in 
bookmarks (sidebar) appears to be raised normally.

OS: w95, NT4 SP3
Build: 2000040208- 2000032718 nb1b was last build that didn't exhibit

Steps to reproduce:
0. Open a new mozilla instance (app preferably).
1. Browse somewhere, like www.netscape.com.
2. Click a link, like 'FedEx Shipping' under 'Shipping Center' heading (for the 
sake of getting some session history).
3. Upon page load completion, right-click in main-window content area, maybe in 
the 'Tracking' area.
4.  No context menu appears.  Hit 'b' to go back.  After page loads, hit 'f' to 
go forward.  Continue hitting 'b' and 'f' till fingers get tired.
5.  Issuing additional right-clicks won't display a context menu, but it might 
cause main-window to stop refreshing the content area, like on netscape.com.  
yahoo.com and microsoft.com pages reloaded, but some history entries disappear 
sometimes.

Looks like the first right-click for the main-window session does it for the 
life of that instance.  Problem affects main-window instance in which phantom 
menu was raised- other main-window instances in the same app instance are safe. 
 As far as i can tell, the phantom menu can't be dismissed, and main-window is 
dysfunctional (text boxes accept no input, for instance- phantom menu has 
keyboard focus) until it the browser instance is closed.

Comment 1

18 years ago
See also bug #34114


*** This bug has been marked as a duplicate of 34079 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 2

18 years ago
verifed dupe... context menus...
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.