contextual menus do not come up

VERIFIED FIXED in M15

Status

()

P3
critical
VERIFIED FIXED
19 years ago
11 years ago

People

(Reporter: puetzk, Assigned: eric)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+])

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
From Bugzilla Helper:
BuildID:    3/30/2000 smoketest

contextual menu support appears to have regressed

Reproducible: Always
Steps to Reproduce:
1.right-click on the page obackground or on a link

Actual Results:  nothing

Expected Results:  the contextual menu should have come up

Comment 1

19 years ago
I can also confirm this bug on linux (zac9@cdc.gov)
(Reporter)

Comment 2

19 years ago
waterson says contextmenus are broken on windows too, marking XP.

OS: Linux → All
*** Bug 34086 has been marked as a duplicate of this bug. ***

Updated

19 years ago
Keywords: regression
Keywords: dogfood

Comment 4

19 years ago
this is a crasher. Console in Linux now displays the position of the
context-menu twice, but no context menu appears. And god help you if it only
appears once: crash. Adding attachment of a backtrace.

Comment 5

19 years ago
Created attachment 7139 [details]
crash & backtrace

Updated

19 years ago
Severity: blocker → critical
Target Milestone: --- → M14
Another example of context cmenus being broken:

If you open up the bookmarks sidebar panel, and context click on a bookmark, 
you'll see a list of available options, but if you try to choose one, the 
command won't fire.
Target Milestone: M14 → M15

Comment 7

19 years ago
For the record: Above attachment was done in nightly build ID 2000033109
I've seen a different effect: after trying to right-click once (on a slashdot banner ad btw -- guess for what), trying (some pages later) to click in the 'Go' menu to get back SEGVs the browser.
I don't know if it's just me (again) or someone else can reproduce (it "worked" several times here).
Build 2000033109 on Debian woody.

Comment 9

19 years ago
I can use the "invisible" context menu items with the keyboard (right click, 
press "S" gets save as dialog)
Also:
I think bug 34114 is related to this one.

Comment 10

19 years ago
bug 34188 and bug 34201 also describe "missing context menus" + side effects.
(Reporter)

Comment 11

19 years ago
*** Bug 34188 has been marked as a duplicate of this bug. ***

Comment 12

19 years ago
*** Bug 34255 has been marked as a duplicate of this bug. ***

Comment 13

19 years ago
*** Bug 34312 has been marked as a duplicate of this bug. ***

Comment 14

19 years ago
This actively blocks testing for me, so raising severity to 'Blocker'. Thanks.
Severity: critical → blocker
*** Bug 34323 has been marked as a duplicate of this bug. ***
adding the smoketest keyword, if this keeps testing from happening, it should
block the smoketests.
Keywords: smoketest
Another example of context cmenus being broken:

If you open up the search sidebar panel, do a search, and then try and context 
click on one of the search results, you should see a list of applicable 
commands, but instead no context menu is displayed.

Comment 18

19 years ago
*** Bug 34201 has been marked as a duplicate of this bug. ***
removing smoketest keyword. smoketests are runnable without this. But i'd
*really* like this to be fixed before we do another release.
Keywords: smoketest

Comment 20

19 years ago
okay, okay, reducing to 'critical'. trudelle notes that this is technically 
'major'.
Severity: blocker → critical
*** Bug 34377 has been marked as a duplicate of this bug. ***
this is a cause of evaughan's box changes, i think. they stopped working for me 
when i applied them.
Assignee: pinkerton → evaughan

Updated

19 years ago
Blocks: 34110

Updated

19 years ago
Blocks: 24686

Updated

19 years ago
Whiteboard: [PDT+]

Comment 23

19 years ago
marking pdt+ per meeting

Comment 24

19 years ago
*** Bug 34285 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 25

19 years ago
fixed
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 26

19 years ago
*** Bug 34715 has been marked as a duplicate of this bug. ***

Updated

19 years ago
No longer blocks: 34110
looks fine on winNT and linux [opt comm bits 2000.04.06.10]. waiting for a Mac
build so that i can verify this puppy...

Comment 28

19 years ago
Note: This did not fix the problem noted in bug 34312 in Composer:
After using the colopicker on the Format Toolbar, the color does not change,
and after that, you cannot type in the document.
Maybe this is a different problem?
verified w/today's opt comm bits, 2000.04.07.09 on macOS, winNT and linux.
Status: RESOLVED → VERIFIED
I've finished a build today off the tip and it is completely busted.  Menus
don't work at all as near as I can tell.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
must've been something really recently checked in, coz i don't see this in this
am's optimized commercial bits (winNT, macOS, linux, 2000.04.10.09/10).

Comment 32

19 years ago
I just pulled and built linux from the tip, and context menus work fine for me.
Not sure (of course) why blizzard is busted.
(Assignee)

Comment 33

19 years ago
They work for me as well. Blizzard can you try again and if they work please 
close this bug out?

Comment 34

19 years ago
Doh -- blizzard@redhat.com wasn't on the CC: -- Chris, evaughan and I have 
context menus working in tip builds on linux. Can you try this again?
I did a clobber build earlier today.  I just updated to the tip ( about 19:00
pacific time ) and built and it's still completely broken.  Sometimes, I can see
a menu flash for a second in the upper left hand corner of the screen for a
second and they it goes away.

Comment 36

19 years ago
I dunno. I just clobbered and built (context menus worked), and then updated
to the tip (~10:00pm) and again context menus worked. [On the other hand, 
building mozilla is not my thing, so I'll quickly concede to any 
possibility that I screwed this up :-)].
blizzard, i cannot repro this using optimized bits for either commercial or
mozilla [2000.04.11.09]. are you still seeing this today?
I hate to say this but it's a problem with something in my tree.  I removed a
change to the gfx/src/gtk/Makefile.in that I had made and it works fine.  Why? 
I have no idea but it's not your problem, it's mine.  Sorry for the
inconvenience.
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED
np! :-)  verif.
Status: RESOLVED → VERIFIED

Updated

11 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: bugzilla → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.