Closed Bug 343005 Opened 14 years ago Closed 14 years ago

Font setting-dialog way too small when win-UI font is larger then "Tahoma"

Categories

(Firefox :: Preferences, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 283697

People

(Reporter: zappa_lot, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

The font setting-dialog ist way too narrow when Windows is running with a different font-setting for dialog-box-text than "Tahoma 8pt". See example-URL, nuff said.

That annoyance came to life ever since someone decided to make the preference dialogs static in size. Under Linux, however, the dialog is still resizable so this is limited to the Windows environment (from what I can check).

Reproducible: Always

Steps to Reproduce:
1. Set Windows UI-dialog-Font to "Verdana 9pt"
2. Open advanced font-dialog in Firefox-preferences
3. Behold

Actual Results:  
The dialog box turned out to be way too narrow

Expected Results:  
Use some function similar to "getTextExtent" to adjust dialog width, or make the dialogs resizable again (as they've been before 1.0.5 or whenever)

*** This bug has been marked as a duplicate of 338184 ***
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

*** This bug has been marked as a duplicate of 283697 ***
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.