Closed Bug 34302 Opened 24 years ago Closed 24 years ago

Unable to create new/automigrate/migrate a profile and launch


(Core Graveyard :: Profile: BackEnd, defect, P3)



(Not tracked)



(Reporter: agracebush, Assigned: racham)


Steps to reproduce: 
1. remove ~/.mozilla
2. Install build 2000-04-03-08M15 for Linux
3. One 4.x profile to be automigrated- fails
4. Use -profilemanager option to create new
5. press new, nothing happens, move mouse, fail
Note* unmigrated profile shows up here-regression to old behavior

If I create a profile/migrate a profile from a previous build- I am able to 
launch with those profiles
No profile manager functions are successful (new,rename,delete,migrate)
also note- when press delete, system hangs - not crash
using build 2000-04-03-15M15, I did not see this behavior
Profile Manager functions were slow/choppy but successful 

will check 4/4 builds and if successful, mark this invalid
Used 04-05-09-M15 commercial build:
I cannot migrate the profile from 4.x by using today's build.
I can only create new profile from Netscape6.....
Bug#34744 already logged for Mac platform, if this bug will be invalid, then 
need to add Linux platform on bug#34744....
Grace - do you see this?  If so, we need to mark this dogfood.
Severity: normal → critical
I did not see this yesterday on Linux  but I reran this am and found more 
disturbing things.
1. run with -installer after deleting ~/.mozilla - 4.x profile is automigrated
2. run with -profilemanager next to test other functions- migrated profile is 
not displayed! 
3. rerun with -installer and 4.x profile shows as unmigrated and can be migrated 
adding racham and myself to the cc list.  this sounds like racham's bug.
We should fix this for M15.  Pls set target milestone accordingly.
Keywords: dogfood
this one also belongs to racham, and would be an m15 blocker.

note, I am able to run -installer and automigrate just fine with the build from
sweetlou with build id = 20000040521

leaving this for racham to investigate.
Assignee: selmer → racham
Target Milestone: --- → M15
I can't think of any of the recent chnages I have made would cause. I checked
all these before cheking in the code. I need to see if somethings else is
changed underneath. If someone has console log, please update the bug with the same.
What are the results you're getting when you try this, racham?
Just copy/paste comments from bug#34744:

I tried this morning again for yesterday's morning commercial build. 

The actual results are:

1) I can run -installer and brought the migrated profiles...but the thing is 

after that, I cannot launch mail at all....I can only launch browser.....the 

application is so slow for open the mail at this point entil I need to Ctrl C to 

enforce to exit Netscape 6....I still cannot get into the mail....

2) I tried to use -profilemanager after -installer...and it is totally empty in 

the profile manager.....I can only create new profile here

I don't see the behavior this bug addresses with 4th build I have on my lInux 
box. I was able to migrate, create new profile, rename and delete (Only thing I 
noticed is that the dialogs are coming up really slow. But that's a different 

I may have to pull and build today's (4/6) build.

Adding ben to cc list.
using build 2000-04-05-20-M15, I am able to run successfully
ie automigrate with first run (./netscape -installer)
create new,rename,delete with second run (./netscape -profilemanager) -the 
automigrated profile does show and shows as migrated.
Haven't seen this behavior with the latest linux bits from sweetlou. Marking
this worksforme.
Closed: 24 years ago
Resolution: --- → WORKSFORME
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.