If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Mac: Cannot migrate the 4.x profiles to Netscape6

VERIFIED FIXED in M15

Status

MailNews Core
Profile Migration
P3
major
VERIFIED FIXED
18 years ago
9 years ago

People

(Reporter: Karen Huang, Assigned: use leaf@mozilla.org)

Tracking

({pp, regression})

Trunk
PowerPC
Mac System 9.x
pp, regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Used Mac 04-05-08-M15 commercial build:

Cannot migrated the 4.x profiles to Netscape6

1) After created profiles from 4.x
2) Tried to go to Netscape 6 (I deleted Document & mozilla registry already)
3) Actual Results: There is no 4.x profiles display on Netscape 6 profile 
manager to allow users to select the profiles to migate.

Expected results: Should display the existing 4.x profiles on the Netscape 6 
profile manager and allow users to select those profiles to migrate.
(Reporter)

Comment 1

18 years ago
Sorry. Platform should select Mac.
Severity: normal → major
OS: Windows NT → Mac System 9.0
Hardware: PC → Macintosh
(Reporter)

Comment 2

18 years ago
I mean I deleted Document|Mozilla|User50 before migrate 4.x profiles on 
Netscape 6.....
(Reporter)

Comment 3

18 years ago
Problem also occurred on Linux platform, can only create new profiles from 
Netscape6 but cannot migrate profiles from 4.x. No problem on Windows platform.
Adding pp, regression & beta2 on the keywords.
Keywords: beta2, pp, regression
for linux, you are running with -installer right?  what gets dumped to the 
console?

Comment 5

18 years ago
I think this needs to be fixed for M15.  Mark dogfood for PDT team's evaluation. 
Grace - you're seeing this too, right?
Keywords: beta2 → dogfood
(Reporter)

Comment 6

18 years ago
Yes. I run -installer. I need to check on Linux in office tomorrow. 
adding racham to the cc list.  not sure who's bug this is yet. this is
definitely a m15 blocker.
Target Milestone: --- → M15
using summary, according to comments from huang.
Summary: Cannot migrated the 4.x profiles to Netscape6 → [mac / linux] Cannot migrate the 4.x profiles to Netscape6

Comment 9

18 years ago
I think bug 34644 is the same as this problem- on the Mac
bug 34302 is for Linux
I will update 34302

Comment 10

18 years ago
This really doesn't sound like the actual migration code.  It sounds more like 
the Profile Manager isn't reading the 4.x registry files (or whatever it reads) 
to determine if there are old profiles.  I'm reassigning this to Bhuvan.
Assignee: dbragg → racham
as I noted in bug #34302, "netscape -installer" on linux worked for me in build
2000040521 (a commercial build from sweetlou)

leaving for racham to investigate.

Comment 12

18 years ago
I can't think of any of the recent chnages I have made would cause. I checked 
this functionality before cheking in the code. I need to see if something else 
is changed underneath. If someone has console log, please update the bug.
(Reporter)

Comment 13

18 years ago
Seth. Sorry. I gave you wrong information last night......
I tried this morning again for yesterday's morning commercial build. 
The actual results are:
1) I can run -installer and brought the migrated profiles...but the thing is 
after that, I cannot launch mail at all....I can only launch browser.....the 
application is so slow for open the mail at this point entil I need to Ctrl C to 
enforce to exit Netscape 6....I still cannot get into the mail....
2) I tried to use -profilemanager after -installer...and it is totally empty in 
the profile manager.....I can only create new profile here
 
(Reporter)

Comment 14

18 years ago
Since Grace already logged & updated bug#34302 for Linux. 
Let's just update the comments in bug#34302 and Grace can mark this bug as 
duplicate of bug#34302.
But, Grace, it seems that bug#34644 is for Mac AIM menu missing problem, it's 
not migration problem.......

Comment 15

18 years ago
Karen,
 bug 34613 is the one I meant- and it is related to bug 34644- both seem to be  
packaging issues- using the .sea.bin file you won't see this problem. 
Sorry about the mixup
Grace
(Reporter)

Comment 16

18 years ago
Thanks for the updates. 

Comment 17

18 years ago
This seems not to be happening with new mac bits and latest linux bits. However,
as the browser comes up, it looks like something on the first page is taking up
the entire cpu cycles. Seth will be working on this with Karen. Keeping this bug
open if there is any relation and till I hear more updates from Seth & QA.

Comment 18

18 years ago
This turns out to be a build team problem (Mac build). NetscapeInstaller.sea.bin
bits are corrupted or wrong bits are getting downloaded. Netscapemac.sea.bin
bits of the same are just working fine. On Linux, no problems are seen. It's
just mac. So, I guess QA team should team should proceed with
Netscapemac.sea.bin bits.

Reassinging this to leaf.

Karen, you should probably grab the next available Installer.sea.bin bits and
see if the problem persists and update the bug with your results.
Assignee: racham → leaf
(Reporter)

Comment 19

18 years ago
Yes. I already tried Mac on 04-06-15-M15 Netscape6Installer.sea.bin build -- 
still having problem for migration (empty from the profile manager).
I need to go back to use 04-05-08-M15 Netscape6-mac.sea.bin build or try on 
04-06-15-M15 Netscape6-mac.sea.bin build.
Like racham said, there should be a problem for Netscape6Installer.sea.bin 
build...but Netscape6-mac.sea.bin build is fine.
(Reporter)

Comment 20

18 years ago
Updating this summary back to Mac since Linux does not have this problem now 
(except the start page problem which already address on bug#34871 for Linux)
Summary: [mac / linux] Cannot migrate the 4.x profiles to Netscape6 → Mac: Cannot migrate the 4.x profiles to Netscape6

Comment 21

18 years ago
Leaf, please add some comment to this bug or reassign.  Do you need any help?

Comment 22

18 years ago
I think this is a problem that jj is working on right now, i'll add a dependency
on the bug he's working on wrt installers.
Status: NEW → ASSIGNED
Depends on: 34644

Comment 23

18 years ago
hoping that jj's bugfix covers this problem as well.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 24

18 years ago
Actually, I tried for today's Mac Installer build.
It seemed that it's working fine now......

Comment 25

18 years ago
working on this week's builds - 2000-04-14-(both M15 and M16)
Status: RESOLVED → VERIFIED

Updated

13 years ago
OS: Mac System 9.x
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.